Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
637 Posts
Discussion Starter #1
Hey guys, I'm tracking a problem I can't figure out, around the fourth of July, my front passenger side strut seemed to be very hard. You would hit a bump and it would almost shatter your spine. I took a look and sure enough, the coil spring was in half. I replaced it with a brand new one from advanced (the whole assembly, not just the spring), and its still really hard. The other side is fine. I know this is am economy car and they don't have the smoothest ride but its really annoying. When I did the assembly made sure to check the tie rod ends and axels while I was in there and the control arm and ball joint look fine. Any ideas on what else could be causing this hard ride? Live in New England (CT) so the roads suck here.
 

·
Premium Member
Joined
·
44,595 Posts
Moved to Brakes, Suspension & Chassis.

That's odd, while you usually do both sides at a time so they match there shouldn't be a problem with a new one. Shot shock & worn spring on the other side would def. feel softer - but the new one shouldn't be a rock.

How does it move on smoother bumps? Normal smooth travel?
 

·
Registered
Joined
·
637 Posts
Discussion Starter #3
Yeah its generally fine. Just a little tough. I'm just wondering if it's just because its an aftermarket pos strut assembly
 

·
Registered
Joined
·
521 Posts
I bought a set of those for my brother-in-law's Escort when one of the bearing plates rotted through and the strut was poking into the cabin. They'll carry you through, but yeah, not much for ride.

Toby
 
1 - 7 of 7 Posts
Top