Focus Fanatics Forum banner

Rough Idle

216 Views 3 Replies 3 Participants Last post by  pinball
Hi folks
I suddenly started getting a rough idle and check engine light on my 2012 a few months ago. I noticed oil in spark plug so changed valve cover gasket. I went ahead and changed spark plugs and coils. I got a code about emissions so I installed a new catalytic converter. The check engine light went off and it runs better. But I get a rough idle at a cold start.
I took off the intake manifold and cleaned off the valves. I changed the fuel injectors. Still idles rough.
At a cold start it idles at 1250 for about a minute then drops to about 875. It also seems to be rough when accelerating. Has anyone had similar issues?
1 - 4 of 4 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Hi folks
I suddenly started getting a rough idle and check engine light on my 2012 a few months ago. I noticed oil in spark plug so changed valve cover gasket. I went ahead and changed spark plugs and coils. I got a code about emissions so I installed a new catalytic converter. The check engine light went off and it runs better. But I get a rough idle at a cold start.
I took off the intake manifold and cleaned off the valves. I changed the fuel injectors. Still idles rough.
At a cold start it idles at 1250 for about a minute then drops to about 875. It also seems to be rough when accelerating. Has anyone had similar issues?
I’m leaning toward engine mounts going bad. Any thoughts?
 

· Registered
Joined
·
199 Posts
My friend will deal with this rough idling issue on his incoming Focus project. The previous owner recently replaced the spark plugs which also had oil in them. We'll take her in this week after we finished installing the led lights and truck accessories on the F-150 and clear the garage.
 
1 - 4 of 4 Posts
Top