Focus Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,091 Posts
Discussion Starter #1
Okay, My car has 16k miles, and past few weeks i've had a really bad idle. Just tonight I did a gauge test and took a look at the rpms. In Park or Neutral, my rpms will range from 630-820 rpms, it's a very rough idle. This can't be normal, the only things done I have done is a fc2pc pulley kit and a borla exhaust, but I don't think they did this right after i did those two mods. Bad plugs? bad wires? bad engine? any ideas? I think i removed the resonator off the stock intake, could that effect it too?
 

·
Registered
Joined
·
109 Posts
[scratch] I had the same problem with a 2001 ZTS that had just 20K.. Granted I only have a CAI but still, exactly what you described. So I asked around and found out that the OEM plugs and wires that Ford uses are really not that great!! [hatchet]

I used a set of BOSCH Wires and their +4 Platinum Plugs..
[headbang]WHAT A CHANGE!!![burnout]

Installation is a snap, they give you the Dielectric Grease, and the plugs are all Pre-Gapped to save time. Just get some Permatex Anti-Seize compound, and your all set. Took me about 15 Minutes to do the wires and the plugs.

Also, once you do this grab some STP Fuel Injector Cleaner or Just a bottle of the STP Fuel System cleaner.. This way you cover all your bases. After I changed my plugs and wires I poured in the Fuel Injector Cleaner. My car exhaust smelled foul for the first few miles but after a [hihi]"Good"[driving] run on the Highway, the idle was back to normal and everything was fine. I now have about 22K and I am still getting about 275-285 Miles to a Tank-full and the car is so smooth you would swear the engine is off.

I sure hope this will work for you, it's worth a shot.. ..Like I said it worked great for me ..
 

·
Registered
Joined
·
296 Posts
just a thought on the plugs. dont go with the Bosch plat +4! i put them in an 87 stang gt that i had. dont get me wrong their not "bad " plugs, but definately not worth the $8 apiece i paid for then. i would go with regular Bosch plats or autolite double plats.
 

·
Registered
Joined
·
845 Posts
hahaha..blkzx3...I'd agree if the subaru wasn't so damn ugly!! It's a super fast awd production car for the $$ though.
 

·
Registered
Joined
·
109 Posts
I have to be honest with you, the WRX is ugly, no doubt about it.. And I will even give you the whole Super-Fast AWD car... However one of the guys that I work with has a WRX.. He put a CAI, Exhaust, and a ECU-Tek engine management system on it.. Now, it burns oil like crazy, backfires every 5 min's, and the thing detonates. He spent over $3K and is worse off now then if he just left it alone. [?|]

My advice....


[confused] STICK WITH THE FOCUS!!! [8D]
 

·
Registered
Joined
·
7,241 Posts
This is getting off topic, but I have to agree that the WRX is pretty damn ugly. What was wrong with the way the Impreza looked back in the 90's? Looked good then, why didn't they just keep it like that? I mean, plenty of cars with a successful design have stuck with that design for years, most obviously the Beetle.

My other beef with the WRX is the dorky-sounding exhaust. Stock, it's pretty quiet - the ones I've seen running around with an aftermarket exhaust sound like giant fart machines to me. LOUD fart machines. I know, it's because the Subie's have a flat-four and they make a different sound than inline-fours, but it's not a good sound to me. [xx(]
 

·
Broken cars s[:)][:)][:)] :(
Joined
·
18,832 Posts
will getting new plugs void the manufacturers warranty cause they spark at a greater temp and stuff...I remember talkin to a guy at a mercury dealership (back earlier in the year when I had my 00 coug) and he said if u get new spark plugs/wires u will void warranty cause of heat and possibility of earlier combustion...dunno lemme know!
-Joe
PS: Yah those wrx-s look ugly but I kinda like em....why? Who the hell knows! I'd never buy one though I'm a FORD guy! Yah! go FORD!
 

·
Registered
Joined
·
41 Posts
Since it's already O.T. All I see when I look at the WRX is potential. If you want to match it against a Ford you'll need look to the past or pray for the future !
 

·
Registered
Joined
·
9 Posts
Sounds like he still has a lot of learning to do...
The CAI is a waste of money in a REX. The stock one works well.
The exhaust has to be selected based on requirements.
The ECUTek probably isn't turned properly. They MUST be turned to your mods and car. If he has detonation it's a clear sign it not tuned. It could have also blown the engine, which explains the loss of oil.

For performance, I'd take my rex over my focus anyday. Sadly, there's only so much you can do with a zetec.

The ugliness only adds to the charm!

Focus~Racer said:
I have to be honest with you, the WRX is ugly, no doubt about it.. And I will even give you the whole Super-Fast AWD car... However one of the guys that I work with has a WRX.. He put a CAI, Exhaust, and a ECU-Tek engine management system on it.. Now, it burns oil like crazy, backfires every 5 min's, and the thing detonates. He spent over $3K and is worse off now then if he just left it alone. [?|]

My advice....


[confused] STICK WITH THE FOCUS!!! [8D]
 
1 - 10 of 10 Posts
Top