Focus Fanatics Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I’m hoping someone might have some advice for me since the dealership seems to know nothing.

I have an 01 4-door SE automatic with 89K. For the past 30K it has been idling roughly, losing power, and now the engine sounds rough, that’s the only way I know to describe it. I live in LA so I spend over 80% of my time on the freeway. The only good thing is that the gas milege is still as good as when I bought the car. (Around 30 MPG on the highway)

I’ve kept up on the maintenance. I’m actually pretty anal about it. I’ve done all the service requirements (30k, 60k, and even 90K recently), regular oil changes, fuel injection services, and even had the fuel pump replaced after the dealership refused to acknowledge that there was a problem until the car died on me and had to be towed in. The worst thing that has happened with this car is that the entire power steering system had to be replaced at 10K and it's starting to make noise again. Recently they replaced the spark plugs and wiring. I’ve never replaced the timing belt or had throttle service done on it (don’t even know what that is, actually). I’m not sure what else I need to do. I don’t want to spend another $100+ on diagnostics that doesn’t turn up anything.

The dealership has some guys that tell me they honestly have no idea what it might be but they believe there’s a problem while some of the other guys tell me nothing is wrong. It’s getting progressively worse. It’s horrible in the morning. The entire car rattles. Ford says it’s just cold but it shouldn’t take me 30 miles of driving before it “warms up” should it? I’m so frustrated with this car. It’s driving worse than my Honda Accord did at 188K. I’m ready to just trade it now.

I’ve read some of the posts here and many of them list technical specifications that are way over my head. I have no idea about RPM’s since my car doesn’t tell me but I can tell you that they are high. When it seems to actually “warm up” the car still vibrates and feels rough. I used to love driving but dread getting into my car right now.

Anything anyone can tell me would be greatly appreciated!

~Andrea
 

·
Registered
Joined
·
921 Posts
Is the engine running ok? The shaking may be worn out motor mounts. It sounds like the engine isn't stumbling, just shaking, which makes me think mounts.

Perhaps, a dirty Mass Air Sensor, PCV valve, vacuum leak somewhere, clogged cat... [???:)]
 
1 - 2 of 2 Posts
Top