Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello, I recently purchased a 2018 focus st (st3) about 3 months ago. I put an AWE-tuning catback exhaust on about 1 month of owning the car. The RPM shoots up when I press the clutch. The issue isn't happening all the time, but when it does it will do it the entire time the car is on. For some reason I am unable to post a video so here is a photo:
 

Attachments

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Take it to ford, its under warranty. Adding an exhaust should have no effect, nor would it void your warranty. The RPM issues could be a safety issue, get Ford to take a look
Well, I took it to the ford garage that I purchased it at and they told me it was normal. So I took it to a different ford garage and because it isn't doing it all the time that when the mechanic and I went for a drive it didn't do it. I showed him the video and he responded they cannot do anything unless they have visual proof (a video isn't enough). So he asked a different mechanic and the first thing he said was "what kind of tune are you running?" But I'm running the stock tune. They ran the diagnostics on it and showed nothing.
 

·
Registered
Joined
·
3 Posts
If you haven't figured it out yet, check a thread on FocusST dot org called "RPMs actually INCREASE on clutch". It's in the ST Discussions subforum. Looks like it ended up as a bad throttle pedal assembly.

Can't post links yet or I'd toss it in for you.
 
1 - 9 of 9 Posts
Top