Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
So after doing some research here, I came to the conclusion that my Transmission's "A" solenoid was faulty. Car runs great, but when shifting from 2nd to 3rd gear problems are present. If you leadfoot the pedal, the engine revs up, then the trans shifts into 3rd gear but a click noise is heard. If you normally press the accelerator, the transmission will shift smoothly, but it slips sometimes. Any suggestions or tips on this issue? I would hate to spend a lot of money on replacing the transmission unless there is another solution that I could try.
 

·
DTC P0606
Joined
·
3,364 Posts
According to Ford documentation I have, a "soft/slipping 2-3 shift" has the following possible causes:
"Check for damage/fault at PCM, shift solenoid SSE, TFT (transmission fluid temperature) sensor, TSS (turbine shaft speed) sensor and related wiring. Check transaxle for high or low line pressures. Check valve body for contamination, improperly tightened bolts, damaged separator plate and stuck valves/springs. Check servo piston and cover seals for damage. Check band adjustment and band anchor bolt for damage. Check direct clutch assembly for damaged piston, seal, return spring, worn or damaged friction elements and balance piston."
 

·
Registered
Joined
·
81 Posts
Discussion Starter #3
Thanks for the reply buddy!! I will take it to my mechanic and we will check these issues. I replaced the "A" solenoid and the problem continued. Your input is appreciated!
 
1 - 3 of 3 Posts
Top