Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
204 Posts
Discussion Starter #1
I have a bone stock 06 focus se zx5 when I am driving sometimes the throttle will just die. Like my foot is on the gas then it feels like the throttle cable fell out of place and the pedal gets soft like it's not connected to anything it's weird. I checked the throttle cables they seem to be okay although to be honest I feel like it's too long because I have to pull it pretty far back before I feel it pull on the throttle body. I also think it might be out of place maybe not sure is this common with the focus? If you guys like tomorrow I can post up a picture.
 

·
Registered
Joined
·
5,887 Posts
I have a bone stock 06 focus se zx5 when I am driving sometimes the throttle will just die.
Hi Rockstar92,

A picture might help other members make suggestions, but you may want to consider visiting your dealer to narrow down the cause of your throttle loss. They have the right tools to diagnose any problem, and will be able to offer solutions. Have a great afternoon! [:)]

~Natasha
 

·
Premium Member
Joined
·
21,250 Posts
It sounds like the sheath is not clamped down at the TB. Does that make sense? Look at it again closely, and you might even want to have someone sit inside the car and push down on the accelerator for you while you're watching the TB under the hood.
 

·
C2H5OH
Joined
·
11,867 Posts
It sounds like the sheath is not clamped down at the TB. Does that make sense? Look at it again closely, and you might even want to have someone sit inside the car and push down on the accelerator for you while you're watching the TB under the hood.
By the OP mentioning 'pulling' I'd have to agree. Something isn't in the place it should be.

http://duratec.wikispaces.com/modification-TB

Some nice pictures in that link that should help you figure out what isn't where with yours.
 
1 - 4 of 4 Posts
Top