Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1 (Edited)
This was the first time I ran at a track. Turbo Turtle and I went to George Ray's drag strip. You may have seen it on Horse Power TV if you watch it much. We got there early and lined up before they turned on the lights. He's on the left and I'm on the right. He couldn't get traction until 4th gear. It's hard to tell what happened at the end on the video, but I was actually slightly ahead of him at the end of the 1/8th. Right after that he went flying past me.



I decided to do one time trial to see what I would run and got a 10.47 @ 70. They only measure the E.T. there, so I don't know what my 60' is. The trap speed is according to my speedo, so it may be off a bit. I had a bit of wheel hop pretty much every time I launched.

 

·
Fins Up!
Joined
·
4,843 Posts
yeah yeah.. just wait till i get slicks. 10.5 at 87 on low boost is kinda silly, lol. oh well. had lots of fun waisting some tires.
 

·
Fins Up!
Joined
·
4,843 Posts
oh my new build for 500whp will need more slicks than will fit under the focus im sure, lol.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #5
Yeah, I wasn't expecting that to happen when we lined up. I figured you'd have alot of traction issues, but I didn't know it'd be bad enough for me to get ahead of you.
 

·
Fins Up!
Joined
·
4,843 Posts
i didnt think it would be that bad either. i just figured i would loose a second or so and fall behind you for the launch. but i was questioning if i would get out of the 11's until i hit 4th, lol.
 

·
Registered
Joined
·
773 Posts
I went yesterday did a 10.42 at 68.2 MPH
Duratec 2.0L (intake,header,exhaust, 93 octane tune)
 
1 - 7 of 7 Posts
Top