Focus Fanatics Forum banner

PS Pump Going?

1084 Views 15 Replies 7 Participants Last post by  amc49
I'm fairly certain that my PS pump is starting to go. Just started making the whining noise on me. I didn't check the fluid level, but I did turn the steering wheel to each side about 5 times a piece to try to flush it.

What should I check before doing anything? And where wpuld be a good tutorial for doing it? The only challenge I would see is the belt, unless I know where everything is.

I also read on here that it takes tranny fluid? I didn't find the reference in my owner's manual.
PS Pump Going:

http://youtu.be/Uw4-3sA_ScI
1 - 2 of 2 Posts

· Registered
Joined
·
465 Posts
Isn't that the typical PS noise of a Ford? My new wagon makes that noise. I run Mobil 1 trans fluid in my Monte and Saturn, planning to do the same with the Focus unless someone speaks up to say its bad for some reason. FWIW when I switched the Saturn to M1 in the PS system it stopped whinning except for really cold mornings until everything warms up a little.
 

· Registered
Joined
·
465 Posts
Your pump is probably fine. Get a quart or two of Mobil1 ATF and a cheap turkey baster. Pull out old fluid from the reservoir with the baster and top off with fresh fluid. Do this every day for the next few days while driving normally in between. In 3-5 days you'll have essentially flushed your system and the whine should get better or go away completely. Take note of the brown color you pull out on day 1 and keep replacing until you get close to the red you keep adding back in to gauge when you have replaced enough.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top