Focus Fanatics Forum banner

problems with car! car being lazy!?!?!

564 Views 5 Replies 4 Participants Last post by  penguin
So anywayz today i was driving, and well. i was going to merge to the left lane however i stepped on the gas. and it took forever to go faster it went faster but it took a long time to gain speed . so i didnt merge, it never did that before. what do you guys think is wrong. so many damn problems!
1 - 6 of 6 Posts

· Registered
Joined
·
10,815 Posts
bad gas, fuel rail, fuel filter, just a wierd thing that happened, anything.....if it keeps doing it...take it in to get looked at...


maybe your foci isn't getting enough love, and it is letting you know.....[hihi], sorry....had to...
 

· Registered
Joined
·
3,746 Posts
It would be so much easier to reply if people would (a) put the year, as well as the model and transmission (ATX or MTX), of their car in the "What I drive" bit of the profile, and (b) post the car's mileage when asking questions.

So, what year is your car, do you have an automatic or manual transmission, and how many miles do you have on it?
 

· Registered
Joined
·
3,746 Posts
Has it had a fuel pump recall done on it? When was the last time the fuel filter was changed? Did the transmission downshift for you when you hit the gas to merge?

Is this repeatable, or did it happen only once and then go away? Does it only happen when trying to accelerate at higher speeds, or if you hit the gas at 20 mph do you also notice no power then?

As haveblue said, it sounds at first glance like a fuel deliver problem, where the engine is getting insufficent fuel. To test this, you want to see if it happens whenever a high fuel demand is put on the system by the engine, hence the question regarding if the problem is there at WOT regardless of the speed.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top