Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
2004 ford focus xx3:with zetec engine standard shift. Need help went thru water and car wanted to die but it kept on running. We stopped and turned off engine and it would not start and wouldn't turn over. My son popped the clutch and it started we got it home. The multi function transaxle cooling system lite came on the dash and the battery lite. I noticed after I went thru water tried to turn on defrost and had to turn it off cause there was a noise. I'm drying out the car now doors open and hood open. I checked air filter and it was dry. I checked oil and it is clean. I have took plugs out yet. I have had a problem with this car before with the negative cable being corroded and when we took battery out terminals were corroded. Need help. What could be wrong with car
 

·
Premium Member
Joined
·
44,595 Posts
Made you a new thread in General Tech Chat, didn't get attention as a post in 100,000 mile + Focus thread.
 

·
Registered
Joined
·
17,167 Posts
That's a joke right?.................

The car did as it was commanded to, the true fault lies elsewhere.

Drying car out often makes things worse in future, the dirt carried in the water then stays after water goes to short out every electrical part it got in. The water may take a month to get out of some 'weatherproof' electrical connections and the corrosion damage left behind will stay. In a modern car you could just have turned car into junk. Why flood cars are generally considered to be garbage.
 
1 - 3 of 3 Posts
Top