Focus Fanatics Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
527 Posts
Discussion Starter #1
i installed my eibach pro kit this sat. everything seems fine and all with it but when i hit a sumwhat decent bump it clunks like hell. it hits so hard it feels like somethings botteming out or something. i cut the bump stops down. does that sound normal? i put in both the springs and struts.
 

·
Registered
Joined
·
526 Posts
did it come with new bumstops? my friend and I just installed new prokit springs on his '94 'stang and it came with a new bumpstop. Oh by the way we're about half way through the supercharger install on his '94 'stang.[thumb]
 

·
Registered
Joined
·
331 Posts
do you need new bump stops after installing these?
 

·
Registered
Joined
·
527 Posts
Discussion Starter #4
it didnt come with bump stops that i know of. i just cut the factory ones
 

·
Registered
Joined
·
2,805 Posts
mine does that as well. i think it's just hitting the bump stops. however, i thought that the pro dampers came with new bump stops.
 

·
Registered
Joined
·
545 Posts
you may need to get alignment.... i just got mine aligned last week and it made a big difference
 

·
Registered
Joined
·
331 Posts
mine is all aligned with the eibach shocks and springs and it feels like it hits hard on big bumps, so should they be cut? it mostly feels like it is in back
 

·
Registered
Joined
·
550 Posts
my pro system came with new bumpstops... mine still does a bit of a bump here an there
 

·
Registered
Joined
·
176 Posts
This may be a silly question but did you put the top spring retainer back on with the new springs?

Open the hood and have your friend bounce the front end while you look around for the source of the sound/anything loose. If you jack up the body, leaving the a-arm/wheel hanging the spring should still have no play/travel.
 

·
Registered
Joined
·
331 Posts
do you have a picture of the rear bumpstops so i can see if i have them installed on my car or not? I had a shop do mine
 

·
Registered
Joined
·
527 Posts
Discussion Starter #13
i had a problem getting the nuts to seat on the top of the shock tower at first but i got it i dont know if that has anything to do with it. my buddy only put the bottem spring rubber thing on one side. didnt think that would make that much of a difference. ill try jacking up the body today to check the spring. ive been meaning to get it aligned as well but i was going to wait till i get my wheels. thanks for the replies guys.
 
1 - 13 of 13 Posts
Top