Focus Fanatics Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
I have a 2003 Focus ZX3. It is a five speed manual transmission. Very basic. Zetech 2.0 L, Vin 3.

I need to replace the power steering line. It started leaking and caused a small fire when the fluid dripped onto the hot engine or catalytic converter.

I went to the auto parts stores and they are telling me there are two replacements, one has a switchport and the other does not.

Can anyone tell me which one I need?

Thanks.
 

·
DTC P0606
Joined
·
3,364 Posts
The one without.
The pressure sensing "switch" on the Zetec equipped ZX3 is on the steering pump housing.
On the SVT, the pressure sensor is in the line, iirc.
Don't know about Duratecs and later cars.
 

·
DTC P0606
Joined
·
3,364 Posts
You can actually splice and relocate that line using the proper high pressure compression fittings on the metal portion of the line, if the trip to the mechanic doesn't work out. A bit involved but prevents the leak/fire scenario from re-occurring. CFM sells a kit intended more for when you replace the stock exhaust manifold with an SVT header but it would work in this circumstance, too.
http://www.c-f-m.com/performanceparts/pc/CFM-Power-Steering-Hose-Relocation-for-00-04-Focus-Zetec-w-SVT-Header-130p124.htm
 

·
Registered
Joined
·
85 Posts
Discussion Starter · #5 ·
BC, my mechanic seems to have identified my power steering line as having the in-line sensor. He got the part today after looking at my car and showed me a nut connector in the line that he says mine also has (though I hadn't noticed it when I was looking at it previously).

I do trust my mechanic, so I wonder if some 2003 Zetech ZX3 may have been built using the different pump/line, or maybe mine was previously replaced. Don't know because I don't know the whole history of the car. But thought I should update the thread to reflect this possibility.
 

·
Registered
Joined
·
7 Posts
Can anyone here help me? I just replaced the power steering pump on mu sons 03 zx3, got everything bolted on and hooked up. O ly to realize the new pump has an extra line port right om the side of the high pressure flare fitting.... my old pump did not have this.... what is it for? And I do not need it, apparently. So how can I plug, or cap it? Tia Frank
 

·
Registered
Joined
·
2,013 Posts
Can anyone here help me? I just replaced the power steering pump on mu sons 03 zx3, got everything bolted on and hooked up. O ly to realize the new pump has an extra line port right om the side of the high pressure flare fitting.... my old pump did not have this.... what is it for? And I do not need it, apparently. So how can I plug, or cap it? Tia Frank
Pressure sensor?
 
1 - 11 of 11 Posts
Top