Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
410 Posts
Discussion Starter #1
For some reason every once in a while my whole power system (interior and exterior lights) will dim and come back... its very quick and usually lasts for a while? It doesn't effect performance at all and it isn't linked to the alternator (I tried reving) I do have an amp and sub but its not from that... any ideas?
 

·
Registered
Joined
·
104 Posts
Check your battery terminals. Check your ground (your ground that the negative battery terminal connects to). If it isn't that ground then check other grounds throughout your car (if you have a haynes manual it will list your electrical diagrams in the back of the book). When looking for the week electrical connector check for one that has several (majority) different components using it as their ground. If you can't find it take it to a dealership, they can more easily find it. And if your vehicle is still under warranty skip all the steps I have just told you and take it there, 'cuz it will be covered under that if so.
 

·
Registered
Joined
·
283 Posts
it might not be directly connected to your amp for your system, but it can indirectly affect it so just in case i would get a power coil and and that way you wont have any future problems because your electrical is completely connected.
 

·
Registered
Joined
·
25,621 Posts
Depends on how big your amp is, you may need a cap, but I would check the batt. connections forst for looseness and second for corrosion.
 

·
Registered
Joined
·
410 Posts
Discussion Starter #5
no it's definatley not coming from the amp... I thinkit's coming from a poor connection somewhere
 
1 - 5 of 5 Posts
Top