Focus Fanatics Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Heres the story:
My wife and I were driving to work and our engine stalled at a stoplight a couple times with the battery light coming on. After work we drove home and during our freeway drive everything started to dim. We jumped off the freeway and parked as the lights and everything were just about off.
Now its my understanding that everything runs off the alternator once the car is running so I assume that this was the problem.
We go to the auto parts store and pick one up and when we get back to the car we realize that getting to it is not going to be easy. So we need to figure out how to get the car home. My wife suggests that we try and start it and I state that chances are its not going to work. She starts it right up and it drives for about 7-8 miles before dimming again. We pull over to the side of the road and I attach jumper cables for a few minutes and we re-start the car. It lasts for another 7-8 miles and then dims again. We repeat the jump and we get it home.
Keep in mind that everytime we restarted it and drove the 7-8 miles for the beginning it seemed that the lights were full blast for 70% of the trip.

I am leaving work early today to go and change out the alternator but wanted to ask here first. Is there a chance that this is battery related, or something else? I just want to get some opinions before taking off ALL the stuff I need to in order to get to the alternator.

Thoughts?
 

·
Registered
Joined
·
1,484 Posts
hm....to me it does sound like an alternator problem. however, i have never heard of lights dimming before
 

·
FUBARCUS
2003 ZX3 2016 FoST
Joined
·
7,787 Posts
If you can get your car to autozone I'm pretty sure that can test to see if it is your alternator. It could be your battery is going completely dead too. How old is the battery. Once again I am pretty sure autozone could help you out there too. I don't know how far it is for you to go to one or anything. Hopefully this is atleast a little help. I remember a few years ago I was with my parents in our van and the lights would flicker and stuff like that and it was a bad battery. I thought of another way you could check is with a volt meter if you have one around.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Im assuming the battery is older, as I dont remember the last time I bought one. So do these symptoms sound like something that could be associated with a dying battery?
I think I will take the battery to AutoZone before I take everything apart and see if it holds a charge. However; like I said, I thought that everything runs off the alternator after the car is running, and the first time the car started after sitting for about 2 hours with no help from a jump, which could indicate a pretty healthy battery?
 

·
FUBARCUS
2003 ZX3 2016 FoST
Joined
·
7,787 Posts
Hmm. That sounds odd I don't think about that I would still have it checked just in case, but if its not the battery check all of your ground wires one could be loose or broke and if it moves that might cause the same problem. those would still be easier to deal with than a whole alternator.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Anyone else? Thanks alot for all your responses thus far. I have a couple things to try when I get home.
 

·
12 years strong
Joined
·
6,882 Posts
it sounds like an alternator to me. its goin bad. it cant keep the charge on the battery, hence why ur lights dim. i replaced mine twice already within the last 4-5 months. i hope u didnt go to advanced to pick up that alternator. i went there and got one and put it on. 3 months later i had my battery light back on. all they sell are re-built pieces of shit. u have the same symptoms i did when my alt. was goin bad. the dash lights would get very dim. its a lil complicated to change the alt. so leave urself some time and patience. its not hard to get off, but a pain to actually PULL it out of the engine bay.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
Great answer and what I was looking for. Someone that has had the same problem with the same symptoms. I appreciate the answer. So the chances of it being the battery is pretty slim huh??
 

·
Registered
Joined
·
752 Posts
yea mine has done that several times... but my oil light flashes at me too and battery light comes on as well
 

·
Premium Member
Joined
·
7,498 Posts
i bet its the alternator!

I had the same thing happen to me a week ago
 
1 - 12 of 12 Posts
Top