Focus Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter #1
So recently at cruising speeds my car will start to feel like its engine braking when I have my foot at light throttle at about 65 to 70 mph. It only does it for a second or so and doesn't do it often. Well today it did it for like 5 seconds straight and the CEL came on. I was close to the dealership that I work at so I stopped in and grabbed a Solus to give her a scan and pulled the following codes.

P0123 - Throttle Position Sensor/Switch A Circuit High Input
Technical Description

P0122 - Throttle Position Sensor/Switch A Circuit Low Input

P1120 - TPS voltage out of range

Anyways I orded a TPS because I found one for 30 bucks from NAPA. Have people had problems with these on zetecs? I haven't heard of many but who knows. I also did a sweep of the tps while watching a graph and didn't see any dips or spikes. So who knows. Anyway if anyone has any input let me know.
 

·
Registered
Joined
·
1,632 Posts
Unless you have the updated TB, that TPS you ordered will not work.

You can't just buy the TPS alone you have to buy the updated TB as well from ford and get the pig tail connector to fit the TPS.
 

·
Premium Member
Joined
·
21,250 Posts
I would not recommend NAPA for purchasing parts. Other FF's have had numerous problems with things like motor mounts. Besides, Mike can give you a better price I'm sure.

You should also check the TPS connector to be sure one of the wires is not loose. I can't figure out the high voltage problem other than a possible PCM issue.
 

·
Registered
Joined
·
1,632 Posts
He just has a bad TPS like every other has had and he can't buy just the new tps alone he has to buy the updated TB as well and the pigtail connector.
 

·
Registered
Joined
·
156 Posts
no NAPA parts, please, I bought my engine mount there and I can not regret it more. Why does he have to buy the upgraded TB? can't he just stick with this one?
 

·
Registered
Joined
·
159 Posts
Discussion Starter #7
I tried to do some quick research on the need for a new throttle body as well. Seems like I might only need one if I have an ATX which I don't. So whats the scoop?
 

·
Registered
Joined
·
1,632 Posts
I tried to do some quick research on the need for a new throttle body as well. Seems like I might only need one if I have an ATX which I don't. So whats the scoop?
I would PM Mike, b16sir1991, at Hiblish and ask him. Ford came out with a new updated TB, and since you have a 2000, it applies to you. Don't know if it's just for automatics, could be but not sure.

And since it's a new updated TB, you can't buy just the TPS alone because it is different than what you have now. As well as the connector.
 
1 - 8 of 8 Posts
Top