Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
hi guys need help. got a 1.8 t reg zetec focus. just had a wheel bearing done. car traction control light is flickering around 25-30 mph . its like it thinks im spinninfg the wheels but im not. Cuts power right down so i can barely accelerate. no abs light on. Took it back to the garage but he said he thinks it was the sensor. replaced that and still the same.. any ideas plz.. its a pain in the ass as i deliver stuff for a living and i stop and start the car every now and then so turning it on and off ect is a night mare..

many thnaks
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
sorry just to add to the above .. once its flickering and sloed down at 25-30mph it doewsnt matter if you keep accelerating and fgaining speed it carrys on flickering unless i drive everywhere at 20 mph
 

·
Registered
Joined
·
4,416 Posts
Here is my guess...

The person who replaced the wheel bearing made a mistake and damaged the ABS tone ring. If so, this is causing TC to "think" wheel spin is occurring and is applying the brakes.

Strange that you have no ABS warning/caution indication. A high-end (semi-expensive) OBD scan tool might reveal a hidden (ABS) DTC.

Old & new ABS sensor = good
Old ABS tone ring = needs inspection or replacement

BTW most of our (USA) mk1's are disc on front + drums on back. Do you have 4-wheel disc? Which bearing was replaced, a drum or a disc wheel?
 

·
Registered
Joined
·
1,212 Posts
That would be hell on your mileage too.

I second Marde's guess...damaged tone ring. Not sure if the UK ones have the TC fused separately or not, but you might be able to pull the fuse to work around it until you can get it fixed properly.
 
1 - 5 of 5 Posts
Top