Focus Fanatics Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi everyone, i got a used 2013 Focus mk3, when cold start it idle normal, but after it warmed, it's idle will drop for a second from 750 rpm to 500 rpm ( car shake a little ), i noticed it happen everytime when purge valve ( location near engine ) stop from ticking.
So it process like this :
1. Engine idle 750 rpm for a moment
2. Purge valve start ticking for a few second
3. Purge valve stop ticking
4. Engine idle drop to 500 rpm for a second then get back to 750 rpm
5. Repeat back to no. 1
When engine rpm drop i noticed too its afr goes to 1:22 from around 1:14 with my sct x4 , no dtc and its drive normal on the road
Please tell me it is normal or not? Is it mk3 's engine characteristic?
 

·
Registered
2012 Focus SE hatchback black
Joined
·
755 Posts
You hear the purge valve ticking?
Perhaps the MAF(mass air flow) sensor or throttle body needs to be cleaned. Buy MAF specific cleaner. It leaves no residue when it dries. You can use it for the TB as well.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
You hear the purge valve ticking?
Perhaps the MAF(mass air flow) sensor or throttle body needs to be cleaned. Buy MAF specific cleaner. It leaves no residue when it dries. You can use it for the TB as well.
Thanks for your response Cobrajet67, I touched it so i knew when it is ticking, i already clean MAF sensor and throttle body, checking spark plugs with same result.
 
1 - 3 of 3 Posts
Top