Focus Fanatics Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,105 Posts
Discussion Starter · #1 ·
So I got a set of heated front seats today for my ZX3, got the switches, pigtails off the switches, and also got the pigtails on the seats. Where can I find a how to on wiring them up to work? These are stock seats btw, and all stock buttons and whatnot. Could my ZX3 be pre wired for them? Its an SE model, so I doubt it.... -Dennis
 

·
Registered
Joined
·
1,105 Posts
Discussion Starter · #4 ·
Alright come on someone has to know.... I know Im not the only person that has done this...


So let me start out with what I know here.

On the driver seat harness thats in the car now, its got 3 of the 5 sections with wires running to them. The harness off the new seats, has 4 of the 5 sections with wires running to them.

So, these new harnesses have 10 pins total. The ones in my car now have these ones with wires running to them.

1,2 ... 3,4 ... 7,8



The ones from the new seats have these pins used.

1,2 ... 3,4 ... 7,8 ... 9,10




Here is the wire colors for all the pins

1,2 (Green with Yellow stripe, and Black)

3,4 (Yellow, and Purple)

5,6 (Empty)

7,8 (White with Red stripe, and Purple with Red stripe)

9,10 (Green with Black stripe, and Black with Green stripe)

So what pins/wires control what? The post mentioned above is for the SVT harness ONLY, this is a 2006, and the harness is totally different. Im guessing that the two added pins (9,10) from the new seats are to control the side airbags?

Now, the heater buttons have three pins being used on the harness. These are pins 1, 2, and 4. Both pins 1 and 2 have the same color wires comming from them. Green with a Yellow stripe. And pin 4 has a Black one.




Here is what Im getting at. I pulled out my center console, and it doesnt appear to have the harness already there for the heated seat buttons. At least not that I could see. So are my seat harnesses already wired for heaters or what? Why do the seat harness have a section with a Green/Yellow stripe wire, and a Black one? Are they pre wired for the heaters, and I just need to wire up the switches to them? If this is the case, how do I wire up the switches?? Do I run one of the Green/Yellow striped wires into the seat harness matching wire, and the other Green/Yellow striped wire to some power source, and the black one to a ground? Or do I run one Green/Yellow wire to the seat harness, and the ground to the harness, and the other Green/Yellow to a power source?


Someone please shed some light on this to me......
 

·
Registered
Joined
·
1,105 Posts
Discussion Starter · #5 ·
Alright so, from what Ive figured out on my own....

Pins 9 and 10 are indeed for the side airbags. So that portion is figured out.

I also checked to see if my car had the fuse for heated seats, and it does, so Im going to assume that the seat itself is pre wired, and that its just missing the wiring for the buttons.

Now, for the buttons...

Again, from what Ive been reading, and from what Ive concluded myself, it looks like I need to run the pin 1 wire from the switch, to the pin 1 wire on the seat harness. Then I need to run the pin 2 wire from the switch, to some kind of power source for the heaters, I assume the stereo. Then I need to run the pin 4 wire, to a ground somewhere.

Please someone chime in if Ive got this down correctly. Because if I do, I would like to get it all put in later on this afternoon.

-Dennis



Oh and by the way, I dont see any how to's on this anywhere.... So I guess Ill make one from what Ive figured out.
 

·
Registered
Joined
·
50 Posts
In the post with the svt the link was supposed to go to his original piece. It contained a diagram:

It shows the 10 pin connector with the top row labeled 1-10 from left to right and the bottom row 1-4 left to right, the opposite directions that you show.
I should have the 2006 elec. manual and will research it today.
 

·
Registered
Joined
·
1,105 Posts
Discussion Starter · #7 ·
Alright so I have an update.

I started today by switching the drivers seat out for the new one. I got the harness switched over, and noticed a wire running under the carpet somewhere. I followed it, and it was the harnesses for the switches. So my car is pre wired for heated seats. Now my question is this, in order for them to work, do you have to have them both hooked up? I got the drivers side all done, and the drivers switch. I havent done the passenger side yet, and havent put the switch in... The drivers side isnt working as of now, the switch doesnt even light up. Could that be because I havent done the passenger side yet?


I saw in another post that another guys car was pre wired, but it was missing some short section going into the fuse panel... I looked there and saw the green/yellow wires, if this wire is indeed missing, where does it need to go?
 

·
Registered
Joined
·
1,105 Posts
Discussion Starter · #8 ·
bump

Stuck the second switch in and still nothing. Am I not getting power or what? How come no one knows anything about this :(
 

·
Registered
Joined
·
1,105 Posts
Discussion Starter · #9 ·
Bump


tttt
 

·
Registered
Joined
·
1,105 Posts
Discussion Starter · #10 ·
Alright lets see if anyone can help me out with this....

I multimetered the switches to see if they were getting power, and its a no go for that. So does anyone know where the power for the switches runs to? I dont want to pull up my carpet just to trace the wires... so if someone knows please chime in. Im getting closer to my goals of getting the heated seats again, just a matter now of getting power to them.
 

·
Registered
Joined
·
1,105 Posts
Discussion Starter · #11 ·
Thread can now be deleted, I figured everything out by myself, and now have two fully operational heated seats.
 
1 - 11 of 11 Posts
Top