Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
Hey Guys

So I replace my pcv valve a few months back. I took the old one out and put the new one in toook 5 minutes. Is the valve meant to lock into the hole it goes in? I tred turning it but it dont lock it just goes round and I can pull it out. It doesnt come out itself though.

I have noticed recently oil on the tranny and when I rub my fingers under the thermostat house there is oil there and also oil on the hose for the pcv valce and the top silve of the valve itself.

I think the hose is leaking oil? is all I need to do is replace the hose with a new one? Or can I use a clamp around the hose where is connects to the metal pipe under the thermostat housing?

Iv seen some pictures where there are clamps on the hoses etc but I am not sure if this should be done or if the hose is just push and pull. I tried to take the hose off as well and its stuck on as tight as anything so i think on the weekend I am going to have to give it a good few tugs to take it off.
 

·
Registered
Joined
·
102 Posts
tighten your valve cover and plan on replacing you thermostat housing soon.
I think there was a clip on the hose that you can cut off., then it will come
off mush easier,
I didn't put any clamp on mine since there is no positive pressure on it.

I would buy a new hose from the dealer/online, they are made much better than the original.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #4
The thermostat housing is new, only replaced a couple of months ago and its fine. Just oil under it which is think is from those spraying it out, i jet wash the engine but after abt a week end up with drips on ground and always thers oil under thermo housing and on pcv valve tube.

Shud oil be passing through that rubber tube?
 
1 - 5 of 5 Posts
Top