Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Can somebody help me out with this P 420 code that popped up Is it the O2 sensors? I have a 04 focus se
 

·
Registered
Joined
·
1,831 Posts
Can somebody help me out with this P 420 code that popped up Is it the O2 sensors? I have a 04 focus se
Which engine and how many miles? Original cat? Is the upstream O2 cycling and is the downstream O2 steady?

Paul
 

·
Registered
Joined
·
1,472 Posts
Can somebody help me out with this P 420 code that popped up Is it the O2 sensors? I have a 04 focus se
Replace the rear o2 sensor if its never been done. If it's not that, and your car has high miles, it's probably the cat on its way out.
 

·
Registered
Joined
·
17,175 Posts
If the car is driven a good while missing that will kill the cat. A severe miss can ruin a new one in 20 minutes if not corrected.

If you ever smelled the rotten egg smell, that is the cat going overboard burning too much fuel to ruin.
 

·
Registered
Joined
·
1,271 Posts
It could be one or both O2 sensors, or the cat. Start by testing the sensors, or replacing them if you just want to throw parts at the problem.
 

·
Registered
Joined
·
17,175 Posts
The norm is to start with O2 after the cat.

The info I put up first was to stimulate thinking with owner, if he has knowledge of any of that then changing other parts like O2 simply wastes money. Ignoring things often has a hefty cost to it. But they always seem to want it the hard way.
 
1 - 6 of 6 Posts
Top