Focus Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
post catalyst fuel trim system too lean on bank 1...

55k miles on this engine. I'm wondering if anyone has delt with this on the focus and I guess I'm looking at a root cause or an easy fix without throwing parts at it.

My first instinct is to replace the 02 sensor. But as i stated I'm not looking to throw parts at it.
I'm think thinking to start my cleaning the mass airflow sensor and the throttle body and reset the code and then if that doesnt work just replace the 02 and hope for the best.

Looking for any insight or anyone who delt with this thanks.
 

·
Registered
Joined
·
693 Posts
You could have a vacuum leak somewhere.
I would research as much as you can about this code not just on the focus, but other vehicles and try to learn what other people did to solve it.

I would check all of your hoses, make sure the air box is properly sealed, and check for exhaust leaks around the O2 sensor.

Apparently a fairly common cause for this code is an exhaust leak. Also you could have a bad O2 sensor hard to tell without a scan tool that can read live data.

Sent from my LG-LS997 using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Good advice. I'm using a snap on solus scanner. Dads a mechanic and pretty busy the last couple of days so I really dont like taking up his time as he wont let me pay for it. I'm going off brain storming and his suggestion as off now.

Exhaust leak was a thought would this have to be befor the cat to throw this type of code?

And as for vaccum leak I'm really not noticing much performance wise. Gas milage suffering about 3 to 5 mpg worse ..Could be a small one. I had one rough start idle but was gone as soon as I gave it any fuel and I can usually drive it a good 10 -20 miles till it will code again after I clear it out. Maybe I'll spray some ether around and check that out but everything seems in really good shape under the hood. Very clean car
 

·
Registered
Joined
·
693 Posts
Yep I would think before the cat, or at the cat.
Well you have a nice scanner just read the live data on it, and see if it's moving around properly. It should be switching up and down quickly if it's stuck at a certain number it's a bad O2 sensor.

Sent from my LG-LS997 using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Ended up replacing the o2 sensor... guess what slammed me with the same dang code. Although my fuel milage did improve. Weird.
 

·
Registered
Joined
·
182 Posts
Have you replaced the evap purge solenoid? It's a pretty common failure but I don't recall what code it throws when it craps out. It's 30-40 bucks and takes 5 minutes to replace.
 

·
Registered
Joined
·
9 Posts
P2096 lean code

My experience with P2096 on these 2.0 is almost always vac leak somewhere. Look for a cracked hose or listen for a vacuum leak. I usually grab some Mass Air flow cleaner and spray suspected areas of leaks. The engine will draw that into the intake and the idle rpm will raise slightly as it burns that "fuel". Thats how I narrow down vac leaks on these.
 

·
Registered
Joined
·
9 Posts
P2096 lean code

Your mileage is worse because your engines getting too much air and the ECM is adding fuel to compensate but it cant add enough to keep it from running lean. Hence it throws the code.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
Update. Relaced both o2 sensors in frustration drove about 5 miles got a code went home reset the code. Drive to new Jersey from michigan and drove around for a week and returned home putting 2k miles on the car and the light never returned. So basically doesnt make sense to me but both went bad at the same time and only threw that code. No idea but my air system is clean as heck so no complaints. Minor repair. Think I put 110 into o2 sensors then maybe 15 bucks into mass airflow cleaner and some other trinkets. $125 and no lights I'm happy. Gas milage was 36 mpg on my way to New Jersey. 34 on my way back with alot of detours and major hills in New York. Appreciate all the input on here
 
1 - 10 of 10 Posts
Top