Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Really at a loss now and out of thoughts to. I've got a 03 zx3, last month on my way to work I hit a spot of black ice and took out a corner post and a couple steel fence post. I drove the car out of the field but when I got it in the driveway next to the field it died and hasn't started since. It broke the passenger side control arm and bent the axle and end link along with pushing the fender back enough the passenger door wouldn't open. I checked all fuses and relays. Replaced the cam and crank sensor checked all grounds. It is getting fire and fuel and the button on the passenger side kick panel is like it should be. The timing belt didn't break. It's getting fuel in the head, smells like its flooding. Replaced plugs and wires to. Any suggestions greatly appreciated. Thanks, Jacob
 

·
Registered
Joined
·
2,484 Posts
You can smell the fuel, how did you check for spark?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Yes I can smell fuel. I check spark by removing the plugs one by one and having a friend turn over the motor. All have a blue spark. If it didn't magically jump time without stripping the belt I don't know what else to check
 

·
Vince your Moderator
Joined
·
5,074 Posts
Really, really take a very good look at ALL your fuel lines and connections. Especially around the fuel pressure sensor(pull off the line and look for and cracks around the nipple). A fuel leak on a pressurized system is a serious matter.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Checked all fuel lines from one end to other has plenty of fuel pressure. Would there be another sensor somewhere on the front to keep it from starting. The air bag didn't deploy
 

·
Premium Member
Joined
·
44,595 Posts
"Fuel, Spark, Compression, Timing"

I'd pull the plugs for a look & check compression while they're out as a first step at this point.
 
1 - 7 of 7 Posts
Top