Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hello again everyone, been a member here for sometime just been out of the focus game. This weekend I picked up a 2004 SVT out of Houston. This will be my first Focus that isn't a duratec. The other two foci I have had was a 2006 ZX4 SES and a 2006 ZX4 ST. I know my SVT needs a rear main seal and a clutch job. Anyone have any hints, tips, or tricks for that job? I have my own 4 post lift so that should make things a little easier than normal but any advice is appreciated.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #2
Got the car up on the lift yesterday to check the state of the underside and found it has a eibach front sway bar, unorthodox racing pulley and KW Lowering springs and blown svt shocks...
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
OMG Holy Focus, Tried to do the rear main seal today and things didnt go as planned. I needed to replace the VSS and someone decided to ugga ugga that thing before I got the car. Striped that Torx bolt but my last ditch effort with the impact screw driver saved the day. Got to put everything back together tomorrow and fine two more bolts for the starter cause two were missing. Good to know that the starter will still work with only 1 bolt.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
Got the trans back on and the car is moving under its own power but there is a new noise. Sounds like drivers side cv axle or wheel bearing. Also measured the rear sway bar that looked rather large and turns out its just under 29mm. From what I have found looks like it is the steeda race sway bar.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
Had another successful weekend of wrenching on the SVT. I got the last of the three new motor mounts installed, new axle, new trans seal, and new driver side wheel bearing replaced and now no more weird noise. I also threw some koni front struts and AGX rear shocks that came with the car on to the car. I also installed a factory sub from a 2009 focus into the car with some mk1.5 sony door speakers and it sounds amazing for everything being plug and play. The only other issue I found is the blue wire that goes to the alternator connector came out of the connector so after that is repaired she should be back on the road.
 
1 - 6 of 6 Posts
Top