Focus Fanatics Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
So as I was pulling into my parking lot at work today, I noticed a really strong burning oil smell. As I backed into my spot lots of smoke generated from under the hood. When I popped the hood there was oil over about half of the top of the engine along with splatter on the hood from somewhere over the exhaust manifold. Anyone got any ideas where to start looking? I know I had something similar happen on my Grand Prix that ended up being a blown out oil pressure sending unit. This is an 05 with the 2.0 Duratec engine. On a lighter note, just got approved today for a 2013 ST :)
 

·
Registered
Joined
·
4,409 Posts
Oh yeah, 2013 ST, nice. So, you gunna do it?

Other than a broken valve cover gasket, I have no idea where that oil leak is coming from. Clean it up some, rev engine and looky-looky for the spot it is leaking from.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
Would a valve cover gasket cause that kind of high pressure leak? I always thought the oil was just kinda splashed around under the cover and that if they gasket leaked it would be a slow drip drip leak? I started the car up at lunch and couldn't see anything leaking, and there's a good bit of oil under the car.
 

·
Registered
Joined
·
4,409 Posts
I agree. I've never seen a valve cover leak like yours so.... -dunno. Hell, I don't even know where the oil sender/pressure sensor is on my Focus. Maybe I should go find out.
 

·
Registered
Joined
·
4,409 Posts
Yes, I know ur a Duratec, me too. I said Zetec so you would know that video isn't a match for us. Should be located very similar on our cars tho. Point is; your oil leak should not be coming from the sender, so still lost on your leak on top side of engine.
 

·
Premium Member
Joined
·
44,595 Posts
Is the fill cap still on?

(yeah, I ask the silly questions)
 

·
Registered
Joined
·
637 Posts
Oil pressure sensor, or oil filter are the two most common than come into where I work (General motors cars though). Usually due to an oil change monkey who didn't tighten the filter enough.
 

·
Premium Member
Joined
·
44,595 Posts
Location of the mess & it's not spewing when checked both make it hard to guess the source. P/S/ line leak was another of my thoughts as well.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #17
Yeah not to sure yet. Got it home today then I went and pulled the trigger on a 2013 ST3. This car is gonna get me in trouble. :)
 
1 - 17 of 17 Posts
Top