Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have an oil leak on the passenger side of my 2000 zx3. I am not very familar with all the parts, i'm not much of an auto guy but i am trying to see what the issue is. What i can tell is that the leak only occurs upon starts, I can drive for an hour and park and return to the car hours later with no leaks, just starting I assume when the system becomes pressurized. That area is about 6" from the the inside of the passenger front wheel. It appears to just squirt out almost like 3-4 holes at once not just one stream, could be from a box looking part but i 'm not sure because i just began trying to examine the source. I was just curious if anyone might have any ideas what is leaking and maybe what am i in for as far as repairs. I do have a buddy that is a auto mechanic that could help if its an do at home type job. thanks.
 

·
Registered
Joined
·
2,928 Posts
The oil filter is on that side if it's a Zetec. Don't know if it would actually shoot oil if it was loose.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
yeah it is a zetec... i was really trying to narrow the exact source but my guess was to start looking at the oil filter. Maybe if i get more time i can try to identify it better. Honestly the oil filter does need to be changed ASAP anyways.

thanks for the reply
 

·
Registered
Joined
·
471 Posts
Well, oil filter should be changed everytime you change your oil. Unless you have an extended guard like me and it's good for 12000 km. Otherwise oil filter is changed during an oil change.

It could be that who ever changed the oil did not tighten the oil filter tight enough, but that's just my guess. You have to find the source of the leak.
 
1 - 4 of 4 Posts
Top