Focus Fanatics Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
357 Posts
Discussion Starter · #1 ·
So heres the story, 2 days ago we went to Cedar point, 80mi one way 80mi home. DID Great there, and great all the way home until we stopped at a light 1mi away from my home, the car stalled out. At random, foot was on the clutch just died. Started right back up. Drove to BK about 500ft further than where I was, stalled at the drive through, and reset my CEL (For o2 sensor). I said Okay, ODD means my car just grounded out or died. The car started right back up and made it home. Today I drove up to the bank about 1/2mi away and back, on the way home at a light it started to sputter hard acting like it wanted to die, when I hit the gas it had no power, the dash started freaking out, Battery light popped up so I pulled into a drive way, turned it off and turned it back on. Drove just fine.

Battery is BRAND NEW, only 2 weeks old was purchased BRAND NEW. Spark plugs are about a month old.

Suggestions?[poke]
 

·
Shot me 3 deer!!!
Joined
·
9,247 Posts
when you said dying, i figured it was due to overheating. but it doesn't sound like it. have you pulled any codes in the past month?
 

·
Registered
Joined
·
357 Posts
Discussion Starter · #3 ·
Only code its throwing is for the o2.. And not over heating I got a light installed to turned red if incase the car were to get about a certain temp. I keep very close eye on coolant and oils.
 

·
Registered
Joined
·
244 Posts
check voltage across the battery terminals with car running and not running. It should read about 12 volts when not running and 14 when running.

also, make sure your battery terminals are tight, loose connection to the battery would cause all kinds of goofy issues.
 

·
Registered
Joined
·
129 Posts
Hmm, sounds like a ghost found a new home in your car. Call bill murray and slimer, see if there is anyway they can extract it from the car.
 

·
Registered
Joined
·
627 Posts
when was the last time you replaced your alternator?
 

·
Registered
Joined
·
357 Posts
Discussion Starter · #7 ·
Haven't but ive never had any issues until just the other day.
 

·
Registered
Joined
·
520 Posts
check voltage across the battery terminals with car running and not running. It should read about 12 volts when not running and 14 when running.

also, make sure your battery terminals are tight, loose connection to the battery would cause all kinds of goofy issues.
Should be 12.6v for a full battery. 12.0v is dead.
a bad connection at the battery ground terminal is a possible cause.

When running check voltage at alt stud should be 13v-14v then the battery+ clamp then the battery stud they should all be the same. if not you found an issue

and what is this o2 code that you have code # and description please.
 

·
Registered
Joined
·
357 Posts
Discussion Starter · #9 ·
I am thinking now it may be fuel related, 12.6 on tap with load or car running 13.6-14.2
 

·
Registered
Joined
·
520 Posts
what is this mysterous o2 code?
a front o2 could do this.
 

·
Registered
Joined
·
357 Posts
Discussion Starter · #12 ·
My home made MIL Faulted, so gotta replace the o2, and buy a mil from CFM.. lol
 

·
Registered
Joined
·
26 Posts
Mine has a similar issue to what you described, with the random stallings. When I come to a stop or sometimes just go to push in the clutch ill get a stall. All the codes in my engine pull from the intake system, I have to tune my ecu for my fswerks CAI yet, and there is an intake runner stuck open. I also pull a code for the of sensor which i will have programmed out with the tune along with my egr system. Hopefully this helps you or gives you some ideas on what could be going on with your car
 

·
Registered
Joined
·
520 Posts
Mine has a similar issue to what you described, with the random stallings. When I come to a stop or sometimes just go to push in the clutch ill get a stall. All the codes in my engine pull from the intake system, I have to tune my ecu for my fswerks CAI yet, and there is an intake runner stuck open. I also pull a code for the of sensor which i will have programmed out with the tune along with my egr system. Hopefully this helps you or gives you some ideas on what could be going on with your car
Start with the intake runner stuck open. that's acts like a bad IAC.
 
1 - 15 of 15 Posts
Top