Focus Fanatics Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
209 Posts
Discussion Starter #1
Ok I have an 09 SES sedan and whenever I jiggle the steering wheel while the wheels are straight, I hear this weird knock sound. It sounds like its coming from my front right wheel/suspension area. And it mostly happens while in park. I'm lost, I was thinking tie rod? Any ideas?

Thanks in advance!

EDIT: its coming from the front left
 

·
Registered
Joined
·
1,913 Posts
It is your swap bar endlinks, has been a known problem. Take it to the dealer and they will inspect/replace if necessary.
 

·
Registered
Joined
·
209 Posts
Discussion Starter #3
It is your swap bar endlinks, has been a known problem. Take it to the dealer and they will inspect/replace if necessary.
thanks a lot! Just wondering, what's the purpose of the swap bar endlinks?
 

·
Registered
Joined
·
209 Posts
Discussion Starter #5

·
Registered
Joined
·
1,913 Posts
Yea haha my typing has been horrible today.
 

·
Registered
Joined
·
209 Posts
Discussion Starter #7
Ok so if I got a new sway bar from fswerks, would that solve my problem?
 

·
Registered
Joined
·
249 Posts

·
Registered
Joined
·
209 Posts
Discussion Starter #9

·
Shiny Metal Titanium
Joined
·
3,647 Posts
It's always the passenger side one isn't it..?
My car is an 09 and has 48600 miles on it I'm on my 4th set of front sway bar endlinks.
Stock, MOOG, MOOG, and DominantEng.
Let's hope the dominant ones will be my last set. lol
 

·
Registered
Joined
·
728 Posts
I have an 08 at 53k and haven't replaced anything so far except for the intake and throttle body. Though once I broke a wheel and had to replace the hub assembly/wheel bearing on that side. The only clunk I have is every now and then when I hit a bump just the right way. I believe there was a service bulletin on the front suspension of this generation.
 

·
Registered
Joined
·
302 Posts
I have an 08 at 53k and haven't replaced anything so far except for the intake and throttle body. Though once I broke a wheel and had to replace the hub assembly/wheel bearing on that side. The only clunk I have is every now and then when I hit a bump just the right way. I believe there was a service bulletin on the front suspension of this generation.
My 08 has had no problems either at 26,437 miles and still going strong!. Of course with mileage this high I am thinking of buying a new car. I hope the dealer gives me at least $5000.-$6000. trade for this one!
 

·
Shiny Metal Titanium
Joined
·
3,647 Posts
My 08 has had no problems either at 26,437 miles and still going strong!. Of course with mileage this high I am thinking of buying a new car. I hope the dealer gives me at least $5000.-$6000. trade for this one!
26k is high?? [dunno]
 

·
Registered
Joined
·
249 Posts
I have an 08 at 53k and haven't replaced anything so far except for the intake and throttle body. Though once I broke a wheel and had to replace the hub assembly/wheel bearing on that side. The only clunk I have is every now and then when I hit a bump just the right way. I believe there was a service bulletin on the front suspension of this generation.
I have that too. I hit a pot hole that ruined the tire and now i get a clunk in the front pass side. Haven't taken it in since its lowered. I guess i'll have to install the stock springs before i do. Its just been SO frickin hot!
 

·
Registered
Joined
·
495 Posts
Gotta check the subframe bolts ... one or 2 of mine were tightened when I recently had the car in the shop for a couple of things, and a banging noise I had in the right front when turning to left over bumps is now gone, unless I'm a complete moron and goose it like crazy over the bump(s) ...
 

·
Registered
Joined
·
209 Posts
Discussion Starter #16
ok guys thanks for all of the replies. now i was just wondering if someone could tell me the location of the sway bar endlinks because i want to see if i just need to tighten them or replace them.
 

·
Shiny Metal Titanium
Joined
·
3,647 Posts
Take the wheel off and look for this thing that is attached to the strut and swaybar
 

·
Registered
Joined
·
578 Posts
my passenger side went at 40k then the drvier side at 60k. i was totally miffed. but nothing 20mins couldnt solve. did it yourself and save the 100 dollars.

when you change it out make sure to also have a jack under the control arm. this will allow you to equallize the pressure on the bar and bring it up to the correct height for mounting.
 

·
Registered
Joined
·
209 Posts
Discussion Starter #19
Ok guys I checked my end links and they are tight as can be and they don't appear to be broken in any way. Anybody have any other ideas? I have noticed that it happens a lot when I pull in or out of my driveway.
 

·
Registered
Joined
·
578 Posts
It is the ball sockets on the link that have some slop in them. There is nothing you can do to fix the noise. So live with it until the link fails or replace the link.
 
1 - 20 of 33 Posts
Top