Focus Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My OD light started coming on and I was going 65 mph. It's an automatic and it came out of gear and motor was racing. Also at the same time the speedometer went 0, and the odometer mileage reading went to lines. What is the cause of this. My car is 2003 ford focus 2.3L
 

·
Premium Member
Joined
·
44,595 Posts
Moved to General Tech Chat - somehow this ended up in engine & trans swap. section.


When the odo goes to dashes, one of the common causes is a loss of ground connection at the grounding point to the chassis near the battery.

Loss of ground there can affect the PCM, and the trans is electrically controlled for most functions.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
So could this cause tranny to disengaged? When the over drive light comes on speedometer goes to zero, and when the car is in motion, " foot on the gas" the engine just race's like it's in natural. I've also noticed when this happens, the automatic doir locks take longer to lock. All this happens together.
 

·
Registered
Joined
·
4,416 Posts
Can it just be solenoid A and or B
It could be one or more of the 6 solenoids; but with your symptoms, please put that thought on hold.

Go back and read what Sailor advised you. Your symptoms indicate the PCM burped/rebooted while driving! This likely happened because of a fault in the charging system. Your first step should be to disconnect, clean and inspect the battery cables & terminal lugs; and the chassis ground cable that the battery uses-> @drivers side wheel well.
 

·
Registered
Joined
·
17,309 Posts
Three threads with this now, we get it already.
 
1 - 8 of 8 Posts
Top