Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1
I just installed a new set of break pads. It's easy to do and I've done it before many times.
But when I drove tested the car there was a sound like something on the rotor hitting the pads and happens only when I break. Faster sound when driving, then decreases when going slower.
I carefully inspected everything, put everything apart then back together but same issue.
So I put the old pads back and no more noise.
The new pads I pulled them out from a 2005 FF at a junk yard.
Thank you!
 

·
Premium Member
Joined
·
44,595 Posts
Moved to Brakes, Suspension & Chassis.

'05 brakes were different than the '00-'04 ones (first year for the new version) so not getting good results from ones that don't match isn't a surprise.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #5
I thought those brake pads would work since I removed them with the steering knuckle, wheel bearing and rotor they belonged to. But brake caliper wasn't removed.
I didn't compare the '05 pads with mine, but I had bought new pads from Advance beforehand and I compared those with the '05. It's an exact match.
My plan was to use the '05 pads and return the Advance ones.
 

·
Premium Member
Joined
·
44,595 Posts
Don't know what parts you plan on using for your car, but they all are different.

Pads look up with different part numbers BTW, if you fit them on they're similar but still different. (fitted for the larger rotors on the '05)

The '05 knuckle will fit your struts, but not the ball joint stud (larger for '05). Discs are larger, and the newer brake calipers match them. SVT calipers & discs can be used with '05 knuckles, making them a popular upgrade for earlier cars. Stock '05 = the "rally" setup from earlier years (FRPP), and the larger SVT ones from earlier years are the optimum.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #7
I installed the new pads and no noise at the beginning. At times same noise as before but on the third day it disappeared. Brakes work great so far.
 
1 - 7 of 7 Posts
Top