Focus Fanatics Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
560 Posts
Discussion Starter #1
well everytime or atleast almost everytime i put the car in either first or reverse , i give it gas , bewgin to release the clutch and just as it is catching before the pedal it completely released , it lets offf a very loud scheeching/squealing noise that is annoying and embarrassing , it drives fine just makes this nose to top it off the clutch was just replaced not more then maybe 1.5k-2k miles ago.....any ideas anyone , any input is greatly appreciated....
 

·
SVT Fanatic
Joined
·
2,615 Posts
who installed it? maybe it has something to do with the installation or the clutch itself. was the flywheel replaced also? i don't know much about them so sorry i can't help you much.
 

·
Registered
Joined
·
20 Posts
Mine was replaced a couple months ago under the TSB and is doing the same thing. I put about 12k miles on the car in two months (yes, I drive a lot) and it's not doing it as much. I took it back but they couldn't get to duplicate it. It almost sounds like a dust shield or something is rubbing/wearing against a rotating assembly, but could very well be something else.
 

·
Registered
Joined
·
69 Posts
My POS Spec stage two clutch does the same thing-loud squeal when releasing it when hot. Going with Centerforce replacement. Spec clutches suck.
 

·
Registered
Joined
·
1,073 Posts
take it back to the installer...
 

·
SVT Fanatic
Joined
·
2,615 Posts
yeah it sounds like it's either something wrong with installation or the clutch itself isn't right. i wouldn't hope a squeel from a clutch would be normal. if it is, i won't ever be buying it lol
 

·
SVT Fanatic
Joined
·
2,615 Posts
focusjosh said:
not to highjack anything but twighlight what are yer mods that you ran a 14.8 ?

then why did you? [confused] you can always just pm him, you know?..
 
1 - 12 of 12 Posts
Top