Focus Fanatics Forum banner

1 - 10 of 10 Posts

·
Fins Up!
Joined
·
4,843 Posts
Discussion Starter #1
ok for about 2 months my car not started like it is suppose to.

it all started with the starter going out. no big deal i just replaced it. that the ground wire for it was melted and the solenoid was just clicking. so i replaced the ground wire. after that is when the problem really started. it will turn over just fine now, it will just turn over all day and wont start.... most of the time.

you can crank it and it wont start, crank it and it wont start, then randomly it will just fire right up and run all day long and perfectly. then you can shut it off and it wont start.

so i started with the obvious. i checked the ignition, great spark, all the time. i checked fuel pressure, fuel pressure is perfect. i checked the injectors and they have power but as far as i can tell (with out noid lights) the injectors were not firing (not grounding).

so i have been having a problem with the ecu not grounding the o2 sensor for about 3 years. i didnt really care about that b/c i dont need one. but since the ecu controls the ground for the injectors i guess that could be the same kind of problem.... but there are other things that can cause the ecu not to all injector ground. and i want to rule them out before i deal with having for reflash a new one to match my car and then dealing with sct.

first off is the pats system. will it just do starter cut off or can it just cut off the injectors.

the oil pressure sending unit. the oil light on the dash will flash when cranking. is this normal or does the ecu think it doesnt have oil pressure (it does i have a mechanical gauge). will no oil pressure just shut down injectors?

a short somewhere. we have pulled and shook every wire on that car and it doesnt change a damn thing.

the ecu itself...


and other suggestions, help, or some info that i dont know.

thanks for the help.
tim
 

·
Registered
Joined
·
441 Posts
you know you can take the car to ford and they have a machine that they car hook up to your computer and it will tell you exactly which wires are not grounded out and are shorting out and all that crap? I think it's only like 150 or something like that. That would be a place to start. Sounds like you have a wire that is shorting out or grounding out just enough to cause your problem.
 

·
Fins Up!
Joined
·
4,843 Posts
Discussion Starter #4
What all have you changes sence you were here last , how have you set things up for the return system

Tom
i havent changed any thing tom. i played with the tune a little, and ran it about a week on mine. but the first thing i did when this all started was put yours back on it. and it didnt change any thing.

the return system is set up just like it was when i was at your shop except i have the cell now. it has ran perfect like it is since spring break.

i am not taking my car to cavenaugh to have them hook it up, unless it is just for pats. i actually just quit working for them last month. i was one of their techs. i will keep my 150 and find the short if it comes to it being a short.
 

·
I AM DA FOCI FANATIC
Joined
·
3,715 Posts
The few times it did start did the oil light flash then?

I am sure you checked all three engine grounds and made sure they are clean and no corrsion?
 

·
Registered
Joined
·
11,906 Posts
Well the ECU will definitly shut down the motor if it thinks you dont have oil pressure.... have you checked the TPS??

A faulty TPS can cause it to not start then randomly start.
 

·
Fins Up!
Joined
·
4,843 Posts
Discussion Starter #8
no i have not checked the tps. i didnt know it would cause a no start. i will check it though. thanks john.
 

·
Registered
Joined
·
11,906 Posts
If your TPS is shorting out (reading higher voltage during startup.. i dont recall how much is needed).. but if your TPS voltage is above Xvolts the ECU thinks that you have flooded the engine and you have the throttle open trying to clear it out... so the ECU will not allow fuel to go into the engine during this time.
 

·
Fins Up!
Joined
·
4,843 Posts
Discussion Starter #10 (Edited)
clear flood mode. never thought about that.

closest i have come to checking it is cranking it while stomping repetitively on the pedal for about 2 minutes lol
 
1 - 10 of 10 Posts
Top