Focus Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
im trying to figure this out but cant i have a 04 focus that i bought it has a 2.0 split port i replaces the motor and went to fire it up and nothing no starter starter wont even click fuel pump is not kicking in and also the odomiter where it says the miles has nothing all the lights work radio works blower for the heater wipers work i checked the ground i checked all the relays i replced the wire harness i unhooked the battery for a half hour still nothing cant figure it out if any body can help me i would be thankful
 

·
C2H5OH
Joined
·
11,867 Posts
Check and make sure you have an ECU fuse ... I can't recall where it is, but it's in the underhood fuse box.

Odds are you just forgot to hook something back up.
 

·
Premium Member
Joined
·
21,250 Posts
How many grounds do you have?

That sounds like an ECU hose is blown. You might want to find out where the radio noise suppressor is on an SPI. If you ground that wire you can blow a fuse that won't allow the car to start. That is a black wire that should not be grounded. On other engines, it's grounded on the front rt (pass) strut tower. It looks like a black box. If the box, noise suppressor, is missing, then if you ground that wire it blows a fuse.
 

·
Registered
Joined
·
2 Posts
I hit a cow with my 2005 2.ol, it drove home ok, but will not turn over, has a clicking noise in the intake manifold, the intake manifold tuning valve? broke off, but the clicking noise comes from another part of the manifold. Would the antitheft system cause it to not turn over?, I took the starter off and it spins good.
 

·
Premium Member
Joined
·
21,250 Posts
I hit a cow with my 2005 2.o
You hit a cow. Check the battery cables, and make sure that there's no damage to the engine compartment- especially the air cleaner and air intake if you hit on your side.
 

·
Registered
Joined
·
2 Posts
Yeah, it has a cracked throttle body and a little thing that sticks into the intake manifold that auto zone calls a intake manifold tuning valve, but nobody sells it, I will probably just plug that off and install a new throttle body, but, it should turn over, i hooked up anew cable.
 

·
Premium Member
Joined
·
21,250 Posts
That's called "Intake Manifold Runner Control" in other places. It's what turns the tumble flaps. There is a tumble flap delete kit available. Pics would make sure we have the right part that's damaged. The IAC is in that area as well. It's available everywhere.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
im trying to figure out what amp the ecu fuse is any body know or where its located at in the fuse box and also now the raio turned on but no sound they turned it off and know radio wont turn on and on the odometer reads ------ just like that got me stumped if any body knows any thing thanks
 

·
C2H5OH
Joined
·
11,867 Posts
"-----" means the ECU is not sending a signal to the gauge cluster and most times not powering up.
IIRC the ECU fuse is a 10 amp one, you can get a free copy of the owners manual here --> http://www.focusplanet.com/#Focus Owners Manual It will list the fuse locations.
 
1 - 10 of 10 Posts
Top