Focus Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2002 automatic transmission. Recently we did a coolant flush and changed the thermostat. After that it started to stall out at stop lights. We changed the air filter, ran fuel cleaner through, and changed the PCV hose. Plugs and wires were done not long ago. It seemed to fix the problem but it did have a check engine light come on reading mass air flow was blocked. About a week or so went by with it running normally. Then the car stalled out at an intersection. It wouldn’t shift from park, the brake pedal is hard. Got it to shift by using the shift release and got it towed home. We have changed the ignition switch and that did not help. It gives no crank at all, break lights and dash lights do not work, the windows will not roll up. When you open the drivers door the buzzer goes off like the key is in the ignition but it isn’t. The interior lights work and the radio works fine but will not turn off even with the key out. PATS light always has a slow blink. Checked all the fuses and they all look fine. I am kind of at a loss. Thinking maybe neutral safety switch or break light switch? Any help would be great.
 

·
Registered
Joined
·
1,122 Posts
2002 automatic transmission. Recently we did a coolant flush and changed the thermostat. After that it started to stall out at stop lights. We changed the air filter, ran fuel cleaner through, and changed the PCV hose. Plugs and wires were done not long ago. It seemed to fix the problem but it did have a check engine light come on reading mass air flow was blocked. About a week or so went by with it running normally. Then the car stalled out at an intersection. It wouldn’t shift from park, the brake pedal is hard. Got it to shift by using the shift release and got it towed home. We have changed the ignition switch and that did not help. It gives no crank at all, break lights and dash lights do not work, the windows will not roll up. When you open the drivers door the buzzer goes off like the key is in the ignition but it isn’t. The interior lights work and the radio works fine but will not turn off even with the key out. PATS light always has a slow blink. Checked all the fuses and they all look fine. I am kind of at a loss. Thinking maybe neutral safety switch or break light switch? Any help would be great.
Since you have multiple systems out I would not bother with the NSS or brake light switch - I believe your problem is more systemic. From all the issues you are having I would supect that the ignition switch you intalled to be defective or installed incorrectly, etc. Was it a new switch? Who installed it? Were the issues identical before/after the new switch install?

BTW when you say 'dash lights do not work' do you mean the yellow/red warning lights on the instrument cluster that normally light up when the key is turned to ON but the engine is off, or do you mean the instrument cluster/HVAC cluster illumination lights that come on when the headlight switch is turned on?

Paul
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
The ignition switch was new from advance auto and we installed it, we have had a lot of beaters over the years so we are pretty handy. There are no dash lights like none at all, nothing. Headlights and taillights work along with the interior lights and the radio. The car has been sitting for a week and they all still work. We did try to jump start it but that did not work. Since some electronic systems are still working fine even after a week and others are completely dead I don’t think it is an alternator or battery issue. Do you think it could be a grounding issue somewhere?
 

·
Registered
Joined
·
1,122 Posts
The ignition switch was new from advance auto and we installed it, we have had a lot of beaters over the years so we are pretty handy. There are no dash lights like none at all, nothing. Headlights and taillights work along with the interior lights and the radio. The car has been sitting for a week and they all still work. We did try to jump start it but that did not work. Since some electronic systems are still working fine even after a week and others are completely dead I don’t think it is an alternator or battery issue. Do you think it could be a grounding issue somewhere?
When you try to crank the engine do any of these lights dim?

You never answered my specific question:

BTW when you say 'dash lights do not work' do you mean the yellow/red warning lights on the instrument cluster that normally light up when the key is turned to ON but the engine is off, or do you mean the instrument cluster/HVAC cluster illumination lights that come on when the headlight switch is turned on?

Paul
Paul
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Nothing dims, and the radio continues to play perfectly. I took a video, but can’t find a way to upload it.
 

·
Registered
Joined
·
3 Posts
2002 automatic transmission. Recently we did a coolant flush and changed the thermostat. After that it started to stall out at stop lights. We changed the air filter, ran fuel cleaner through, and changed the PCV hose. Plugs and wires were done not long ago. It seemed to fix the problem but it did have a check engine light come on reading mass air flow was blocked. About a week or so went by with it running normally. Then the car stalled out at an intersection. It wouldn’t shift from park, the brake pedal is hard. Got it to shift by using the shift release and got it towed home. We have changed the ignition switch and that did not help. It gives no crank at all, break lights and dash lights do not work, the windows will not roll up. When you open the drivers door the buzzer goes off like the key is in the ignition but it isn’t. The interior lights work and the radio works fine but will not turn off even with the key out. PATS light always has a slow blink. Checked all the fuses and they all look fine. I am kind of at a loss. Thinking maybe neutral safety switch or break light switch? Any help would be great. Want to find the best battery maintainer, visit autofthings to view more model that you may concern.
Might have issue with starter circuit, try check the fusable link at the starter.
 

·
Registered
Joined
·
19 Posts
Shifter mechanism fails on these cars, making it impossible to shift. Not sure that plays into your other troubles. Easy to replace--search youtube.
 

·
Registered
Joined
·
10 Posts
I don’t know if the car has a body control module (BCM), but if it does, it sounds like that could be part if not all of your problem.
 

·
Registered
Joined
·
48 Posts
I've noticed oddly enough that when the battery goes dead the radio won't shut off. It's the craziest thing! Check the battery for voltage. Don't just assume. When I used to drive a tow truck for AAA I'd constantly get calls for no starts and I'd show up and they'd insist the battery is dead because lights would come on. More often than not it was a dead battery. Check it first. Then charge it. Start the car and check voltage while running. A charged battery is 12.6 volts. A dead battery is 12 volts. And while running it should read 13 bare minimum. And more likely 14+.
 
1 - 10 of 10 Posts
Top