Focus Fanatics Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Today I installed the Stg1 turbo kit (removed from Mike's 2004 SVTF) to my 2002 SVTF. Idle is fine, everything *seemed* fine. When I went for a drive, under load and when boost should be coming on it sounds like a rev limiter and it makes no boost. It literrally feels like I have a parachute tied to my car and I just cant go. Its as if the computer senses the boost and freaks out.

Just so you know, mods are: Stg1 with T3 upgrade, MAFia (set at 4), 55lb injectors, Greddy BOV, MSD Coil and Wires and OEM Plugs, Ex.Cam Gear (set at 0*-1* Advance - as close to zero as I could get), UDP, No Cat, 3" Exhaust.

I didnt unplug my battery (its in the rear of the car and didnt think of it) til I was already gone. But, I flashed the custom tune and it went just fine.

Also, if its relevant, as soon as I start to drive away, the air fuel (aem wideband) pegs rich (goes below 11:1) and it sort of sputters. It only does that on vey light acceleration. The car also stalled out several times but I figure with all those symptoms that its just learning.

The making no boost is the biggest issue. Do you think its a tune issue or something mechanical. I will tell you, the turbo kit was FINE as it was removed from the car. The BOV is hooked up right, wastegate is hooked up right, etc. Also, I have an RLA6 car, and Mike has a ZED0 car...could that be an issue?

p.s. I ruled out traction control (light doesnt blink, and I also pulled the fuse so it was gone...)

Any ideas??? Im at a loss...

Thanks
Russell Rudez
 

·
Registered
Joined
·
1,512 Posts
OT.

Russ, check your inbox.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #4 ·
Blane, responded...

Tom, I got my dyno appt. tommorow at 9am at McNews!! Imagine the luck they had an opening!

Thanks again for the help last night and this morning; that just goes to show how much you care about your kits and your name! I got the kit 2nd hand and you were STILL there for me!
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #6 ·
Excellent, thank you! I will take it on my USB Memory Stick as well just in case any issues arise.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top