Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I just bought an 00 ZX3 auto, with 122k miles. After having it for a few days I noticed a little surge when you are cruising about 1800 to 2200 RPMs. I change all the plugs, changed the fuel filter, changed the air filter, and the oil and filter.
This car is bone stock and is just my new daily driver. Not sure were to start. I do not want to just throw parts at it. Could it bee the Throttle Position sensor?
 

·
Focus Hoarder
Joined
·
3,633 Posts
Yup may have a bald/corroded/dirty spot on the rheostat (the tps is basically a rheostat to sense how far your accelerator pedal is pushed).. my TPS went and my car would absolutely not run right, Would either take off the line like I floored it or it would just stall out, it would idle rough or I would be cruising and all of a sudden it would take off again like I floored it hehehe

I replaced the TPS ( actually the whole throttle body since my TPS was no longer available and was concerned in the past by ford and become a TSB bulletin...

to see if your TPS was changed look at it if the plug is wider then the body of the tps then its the old style if its the same thickness as the plug its the new style ( if needed I can offer some pics of the old and new style TPS's for refference)

once it was replaced the car drives and runs like new except for the tick, like it was a diesel motor (My Wagon that is)LOL

if your Focus is a Zetec most likely they will try to pin you with a $600 bill like me but contact mike on the forums for the TPS update on the 2000 Focus TSB he will give you a great deal on the parts
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the reply, It is a Zetec, I plan to do the install myself. I just need to get the part. My local parts place said they could order it for me. Is there anything special about installing it?
 
1 - 4 of 4 Posts
Top