Focus Fanatics Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
First off, this site is awsome, but to my problem. I bought my SVT last Friday and f[:)][:)][:)][:)][:)][:)]in love it, but both my driver and passenger doors are hard to open. I pull the handle and it takes a bit of muscle to get it to unlatch and sometimes after driving, I go to open the door from the inside, and it wont unlatch. Ill pull it quite a few times, and it will finally unlatch, but it takes awhile. Any help will be much appreciated. Thanks.
 

·
GreyRice WOoT!
Joined
·
10,786 Posts
im with hellacool, is either that, or the latches may have broke on the inside, my sisters car did that, the wires on thehandle cracked and wouldnt open, took lotsa lotsa force hehe
 

·
Registered
Joined
·
1,067 Posts
start off with the easy stuff first... try lubricating the door latches with some spray lithuim grease...

Your car may have been sitting on a lot for quite a while, and the latches have some surface rust on them. Lube, then open and close the doors repeatedly to work the mechanisms back and forth...

If that doesn't help any, then start worrying about possible accident damage etc..
 

·
Registered
Joined
·
291 Posts
The drivers exterior door handle on my "new" 04 SVTF takes more effort to open than the other 3 doors. I figure it is because the drivers door is used 99.9% of the time and is maybe worn or dirty or whatever.

I haven't tried to lube anything yet. I'll try that first but if it doesn't make a difference, I will take it in under warranty.

The door handle release from the inside is fine.
 

·
Registered
Joined
·
169 Posts
yeah both my doors on my 03 svtf are like ahhh.....they swing opened and closed just like new the only thing is the door handle u have to pull hard and then it gets to a certain point and it opens i know my car hasnt been in any axcident at all, maybe its just the mechanics in the door are put together tight and its supposed to be like that???????
 

·
Registered
Joined
·
2,805 Posts
it's typical of ford latches. if you have a 4 or 5 door there's a TSB out to have them lubed up. i had both the latched replaced in my ZX3 while under warranty because they were doing that exact same thing.
 

·
BAD EGG
Joined
·
7,418 Posts
I think the stiff handles are due to them being painted. The locks themselves could be the TSB, had that done to my rear doors. Just my opinion whith what little info we have so far I'd not get too concerned about accident damage due to both doors operating with the same stiffness. I'm thinking this guy needs some TSB luv
 

·
Registered
Joined
·
560 Posts
i have a 3 door hatch. i had this issue as well, and no... it's not an alignment issue. it is the door latches, all you have to do it get some lithium grease like the above poster said. i don't recommend the spray though because it doesn't last long, i'd get the gel. just put some on the metal "u" shaped latch and open and close a couple times and it should be good to go.
 

·
Registered
Joined
·
1,056 Posts
kpSVT said:
I haven't had any problems with my doors and I have a 2002 SVTF.. I would seriously check to see if your car was crashed!!! Hope it wasn't!!!
The doors open normally from the inside, ruling out body alignment as the problem.
 

·
Registered
Joined
·
291 Posts
I was noticing with mine that the exterior handle works fine when the door is open, and I manually latch the striker assembly. It's only when the door is closed when there is a higher effort to pull the drivers door exterior handle.

I am thinking that mine might be because the door could be adjusted too far inward and therefore increases the effort required to operate the latching mechanisms when opening.

I will try to adjust my door out a hair and see if it changes anything.
 

·
Registered
Joined
·
175 Posts
Come on now an accident!!!

I've personally opened quite a few different Focus (my 2 friends and I work at Budget car rental) doors with the same problem he's having. He means when he pull the door handle to open the door and not as it's opening!! It's a very common thing on the Focus.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #14 ·
Thank you everyone for your help. I did get a carfax report when i bought the car and it was not in an accident, so i figure that it is the latch that needs to be lubed. I picked up some spray lube, so ill give that a try. Thank you again.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top