Focus Fanatics Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
298 Posts
Discussion Starter · #1 ·
Ok, last night I was cruising home, I stop at a light and then turn into my subdivision and the car starts shaking and sputtering and all but shuts off. I stop the car and I got CEL (PO352). I was about 500 feet from the house and since the car was still running I drove it home.

The car idles slightly rough and the exhaust note has changed for the worse. It really doesnt rev for crap. It will climb in RPMS but it takes longer to get there and obviously isn't right. I took it around the block this morning and its the same thing.. No power to speak of. No smoke from the exhaust or anything. It was really hard to get it to climb up my ramps.

Spark plugs were not terrible looking but they have maybe 40K miles on them. I went ahead and changed them since I had them out. The coil and wires seem good too no cracks or splits. I swapped in a new stock set of each I have had for months now since I had them out. No change after.

From underneath the car looks like nothing too out of the norm aside from yet another worn-out dog bone trans mount... a little seepage from a trans seal above that mount. The throttle sticks a little bit sometimes too...

I have no ideas whats up with it now since I cleared the code it hasn't come back on but it is still running weak. I have run like 2/3 of this tank of gas so I am not too inclined to think I got bad gas but who knows.

Any ideas?

Thanks Nick
 

·
Registered
Joined
·
2,211 Posts
Code 0352 is ign. coil pri.circuit 2 fault.

This might be the coil pack, but before you replace that, check that little plug with 3 small wires that sticks into the side of the coil pack. Make sure one of the wires aren't broken right where they crimp into the terminals. That's kind of a weak spot as it is, and with that dog bone shot, the motor is probably rocking around more than it should be, making the stress on those little wires even worse.
 

·
Registered
Joined
·
298 Posts
Discussion Starter · #3 ·
yeah it rocks a good bit I have heard it for a few days...I have been driving it pretty tamely since I replaced the last one in September. I'm thinking this one(Napa replacement) was crap to begin with. I didn't see any obvious loose wires anywhere. I finally pulled it off the ramps and when I did the CEL came back.. same code po352. I will go do a once over of that again just to be sure.
 

·
Registered
Joined
·
298 Posts
Discussion Starter · #6 ·
good catch... too bad I gotta go to work tomorrow.. I guess I am gonna be buying all 3 poly engine mounts asamfp.. I had a similar thing happen back in May with my alternator pigtail. I guess I could fix it without an actual plug ehh? I need to drive tomorrow and Ford parts isn't going to be open until Monday and I am sure they will have to order it in.
 

·
Registered
Joined
·
298 Posts
Discussion Starter · #7 ·
Problem fixed and runs better than it used to... I didn't get a new plug assembly but used some small slide terminals a few pieces of wire and some shrink tubing..

Thanks
Nick
 

·
Registered
Joined
·
79 Posts
Thank God for this Forum. [angel] Memorial day weekend and my car shutters. CEL comes on so I run to Autozone to borrow their code reader. Took the code, plugged it in the search and found this thread. Checked the wires and find one broken right at the opening. Of course the stealer isn't open again till Tuesday so I tear apart the pigtail connector, solder on some new wires, reassemble the connector. Plug it in and it fires right up. Couldn't have done it this easily without ya.

[ffrocks]

Koz
 

·
Registered
Joined
·
79 Posts
Went back to Auto Zone to ask to have them clear the code now that i fixed my problem. The guys says no he can't because it's against the law for them to clear codes. He says only a shop can clear the codes. Is that true? I said well let me borrow the reader and i'll clear it myself and he said he couldn't knowing what i wanted to do. [:(!] Needless to say i went back the next day when different employees where there and borrowed the reader. [neener]
 
1 - 9 of 9 Posts
Top