Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
545 Posts
Discussion Starter · #1 ·
Ok, so my car was out of commission for a bit over the past 2 weeks cause it needed brakes badly. When I drove it to the shop, it started real hard like it was going to need a jump, but it did start. Then, the light on the dash with the exclamation mark in the circle stayed on. I got to the shop, turned off the car, then restarted, and it stayed off.
Then driving the car home from the shop, it did the same thing. Started hard, light stayed on. Then I got home, shut off and restarted, and it was off again.

I know why it started hard..just not being run drained the battery a bit, but what's the light for?
 

·
Registered
Joined
·
1,929 Posts
I always heard people say that it is a warning for electrical problems.

I'd check all your grounds and clean up your terminals and battery posts.


edit:
Is the shop you went to a short drive? Maybe you battery did drain out over the two weeks and hasn't had enough time to charge itself back up to the fullest.
How old is the battery?

Either way I'd still clean up everything to assure you are getting good connections.

Anytime I leave one of my cars parked for a long period of time I disconnect the battery. Saves you the hassle of possibly having to deal with a drained battery.
 

·
Registered
Joined
·
545 Posts
Discussion Starter · #4 ·
I always heard people say that it is a warning for electrical problems.

I'd check all your grounds and clean up your terminals and battery posts.


edit:
Is the shop you went to a short drive? Maybe you battery did drain out over the two weeks and hasn't had enough time to charge itself back up to the fullest.
How old is the battery?

Either way I'd still clean up everything to assure you are getting good connections.

Anytime I leave one of my cars parked for a long period of time I disconnect the battery. Saves you the hassle of possibly having to deal with a drained battery.

Yeah, it's a pretty short drive. I actually work at the place..I drove my car there to claybar and wax it up.

I don't think the battery has been replaced since I bought the car in Feb. '06.

I don't plan on taking any action really. The car will be sitting through the week, but by the weekend, it'll be back on the road and I'll let it charge up just by driving it. If I have to jump it once, I'll do it, but I'll park somewhere where there's a hill or somewhere I can push it up to speed to pop start it.
Thanks for the replies!
 

·
Registered
Joined
·
47 Posts
That happened to me a couple weeks ago...come to find out when I put a load test on my battery it was shot. After I put in a new battery I haven't seen that exclamation light come back on again. Before you replace the battery I would have it tested with a load tester (autozone has one near me), and if it seems to hold a charge fine and it passes the load test then you will know it is probably something else. I had a bad connection with one of my main grounds a few years ago and it caused that exclamation light to come on too. Anytime I have seen that light come on in a foci it seems to be mostly electrical related, although I do not know if that is what it is exclusively for...
 

·
Registered
Joined
·
545 Posts
Discussion Starter · #6 ·
Alright..Well, I took my car for a spin around the neighborhood today (with no tail lights) and the light didn't come on, and the car started much easier than before. I figure if I take it out once a day till it's legal again, I shouldn't have a problem. If there is one, I'll just bring it to the dealership I work at and have them test the battery.
 
1 - 6 of 6 Posts
Top