Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
( o Y o )
Joined
·
5,549 Posts
Discussion Starter #1
I live in Florida and we get a bunch of rain this month. I was over in Orlando, I live in Tampa, and it was raining pretty hard. I was in the right hand lane but the drainage wasnt too good. I was taking it slow, but because my splash guard fell off, when water gets tooo deep it gets on the belt. That causes my car to idle and run really badly. And when this has happened before I try to keep it in a gear and let the water fling off. This time I have no idea what happened. When the car has acted weird before in the rain very similar to today, a CEL had never come on before. Now there is one and I have no OBD-II code reader to see what it is.....Should I be concerned? I am thinking about takin it to Ford tomorrow and seeing if they can get the code. I only have a powertrain warranty, would they charge me for reading the code?? Do any of you guys have any ideas as far as sensors or something getting bumped? I live at an apartment and its been raining all day so I havent gone out under the car yet. Thanks for all of your help.
 

·
Registered
Joined
·
1,643 Posts
if the code turns out to be powertrain related, it'll be covered by the warranty. if it's not powertrain related, you'll have to pay for it
 

·
Registered
Joined
·
420 Posts
I can't stress this enough.

I would never ever take my focus to the ford dealership, unless it was to get a DEALER ONLY part. Granted, I bought my car used, without a warranty, but Ford will charge you and arm and a leg, and more than likely it wont be fixed anyways
 
1 - 3 of 3 Posts
Top