Focus Fanatics Forum banner

1 - 20 of 21 Posts

·
Flat Black King
Joined
·
8,203 Posts
Discussion Starter #1
I have been having problems with my alternator and i got the new one and tried doing it myself but cant seem to get it. i would like someone whos done it before help me out cause i need my car. If anyone can help me please let me know ASAP cause i started my new job and cant afford to miss a day. My cell number is 832-766-9832 if any local houston people can help or know of someone thats a mechanic and will come to my house and do it cheap.
 

·
Registered
Joined
·
1,467 Posts
hey, alternators are not the easiest parts in the world for a ford. it seems as ford just went ahead and stuffed it in a tight spot. best thing to do is take it to ford. talk to dj_kurruption (Ryan) over on fj, i believe hes a ford technician .
 

·
Flat Black King
Joined
·
8,203 Posts
Discussion Starter #3
well the thing is is i tried doing it myself and i took the nuts off and unplugged it but i cant get it out of there it barely moves. i need help with that
 

·
Scuba Edition
Joined
·
1,694 Posts
You can drop it out through the bottom. Its a tight fit but it will fit.
 

·
FF PHOTOG ENTHUSIAST
Joined
·
15,097 Posts
There are a few more things you need to take out then ... I find the alternators on our cars to be a crap load of work to get out. It took me like an hour to get mine out.

OH HEY I JUST REMEMBERED ... I will be in Pasadena today all night. You need some help? ? ? ? ? Jeremy I will call sometime today.
 

·
Flat Black King
Joined
·
8,203 Posts
Discussion Starter #7
i just cant get the alternator out to remove it the belt is holding it in.
 

·
FF PHOTOG ENTHUSIAST
Joined
·
15,097 Posts
You need a wrench to move the belt tenchener and it will loosen up. ... Just don't push to hard or you will break it ... can make matters even worse.
 

·
Flat Black King
Joined
·
8,203 Posts
Discussion Starter #10
my battery has been disconnected for a few days already
 

·
Ehh...
Joined
·
6,265 Posts
but get the belt tensioner loosen'd up. move it up but dont do it too hard.
 

·
Flat Black King
Joined
·
8,203 Posts
Discussion Starter #12
Well raymond is coming over to help me hopefully he makes it
 

·
FF PHOTOG ENTHUSIAST
Joined
·
15,097 Posts
Oh I'll be there ... Just need to get off work here in a bit
 

·
Flat Black King
Joined
·
8,203 Posts
Discussion Starter #14
well me and the famous ray finally got the alternator in but the old one was a B!tCh to get out. Cant tell u what we used but we got it without having to take off the motor mount and moving the motor. Now just got to put the belt back on.
 

·
FF PHOTOG ENTHUSIAST
Joined
·
15,097 Posts
Did you get the belt on? [???:)]

I would have to say guys that the alternator on a SPI is actually harder than the Zetec motor ... unless you lift up the motor ... then it is flipped. [:(]

-Ray-
 

·
Flat Black King
Joined
·
8,203 Posts
Discussion Starter #16
not yet but im gonna tackle that today and hopefully get it running.
 

·
FF PHOTOG ENTHUSIAST
Joined
·
15,097 Posts
He did ... just has the car turning off on him ... But he checked the Starter, Alternator, and Battery at AutoZone and all was good there. I was thinking he could check his Neg Cable (Pigtail) or even the ground wires for rust or damage. ... Also maybe letting the car idle for long periods of time to recharge the system. Almost fixed.
 

·
Flat Black King
Joined
·
8,203 Posts
Discussion Starter #19
yea almost fixed just got to find why the battery wont stay charged
 

·
FF PHOTOG ENTHUSIAST
Joined
·
15,097 Posts
I really think it's your negative cable ... I had that problem once and that was the culprit. ... you can get a new one at auto zone for a little under 20 bucks with the right kind of ends and all. ... You know I might have a spare one ... I will let you know.
 
1 - 20 of 21 Posts
Top