Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi I am new to the board and just finished having the Ford Dynamic suspension put on my 05 zx3. Works great but I now have a clunking that we have traced to the end links, the kit did not come with upgraded ones. Does anyone know where I could get some that would fix the problem?
Thanks in advance, Adam
 

·
Registered
Joined
·
2,191 Posts
does it go clunk on every bounce/ bump?

if so, then its the endlink that isn't tight, tighten them up more, and take a test drive.


if you lookin on upgrading them to poly end link, try http://focus.c-f-m.com/index.asp?PageAction=VIEWCATS&Category=1427

depending on your size of the bar, u'll find it ranging from 20mm to 22mm



-----

mine use to clunk after i installed my rear bar.
 

·
Registered
Joined
·
2,191 Posts
make sure you bushing on ur endlink are in the right order.... or eles they won't have clearance from the sub frame.


forgot to mention that
 

·
Registered
Joined
·
28 Posts
The sway bar link bushings should be compressed a bit when installed. You could measure quickly the components in the link to make sure that when the nut is fully tightened that bushings are compressed.

Also make sure the "noses" of the grommets are isolating the bolt from the center of the hole in the control arm and sway bar pad. You may want to try to install with the vehicle on the ground at "ride height". This will allow everything to line up better when the link is tightened.
 
1 - 6 of 6 Posts
Top