Focus Fanatics Forum banner

1 - 20 of 40 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1
I keep getting Navigation Fault: Please see your dealer for service.

I took it into the dealer this morning and they printed off a bulletin from August 24, saying there is "intermittent SD card faults" and to not service the SD, as there will be a software fix "soon". I have gotten those errors before, but I tried to explain to the dealer that this was not intermittent like it was before, that it is constant. The issues I had before, as pertaining to the August 24 bulletin have always resolved themselves within minutes or with turning the car off and on again. This however, brings up the error message in the middle of the screen and wont go away unless I press the OK button, and then it pops back up in about 2 minutes.

There is something wrong with the SD I think, but the dealer wont do anything. They just keep pointing me back to this bulletin and saying there is nothing they can do for now.

Its really frustrating because it not only affects my navigation, but my entire sync system because it makes it totally unresponsive to the point where it wont even bring up the voice prompt until minutes after I have pressed the button, and then when I do my voice input (change song or whatever) it just goes mute and switches back to the music.

I really need that Ford Rep's name on here so I can PM them my details. My dealer does not seem at all interested in trying to fix this for me, which is quite disappointing, so I am hoping theres some other way to get it fixed.

Perhaps I need to call a different dealer other than my local one to see if they will replace the SD card for me?

To be honest, this is just one more thing added to the pile of reasons as to why I am really starting to regret going Ford. They have been nothing but reluctant to help me with any and all issues I have ever had with this car so far (not even 4 months old).
 

·
Registered
Joined
·
109 Posts
Is your Sirius subscription expiring? I only ask because I had the same issue occur for several days when my 6-month Sirius subscription expired. Then it went away once Sirius had completely expired. All I can figure is that the alerting for Sirius somehow screwed up MFT and it produced incorrect error messages. For awhile, nothing would work unless I removed the NAV SD card. Now, the navigation is working fine again (and my MFT is much faster without Sirius, go figure...).

 

·
Registered
Joined
·
94 Posts
Tell me about it, I had the exact same error on day 1. "Fixed" it by pulling fuse #67 and #79 and setting them back. I've had the car for 19 days now and I haven't encountered that error ever since so it might just help you out. Good luck.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #4
Is your Sirius subscription expiring? I only ask because I had the same issue occur for several days when my 6-month Sirius subscription expired. Then it went away once Sirius had completely expired. All I can figure is that the alerting for Sirius somehow screwed up MFT and it produced incorrect error messages. For awhile, nothing would work unless I removed the NAV SD card. Now, the navigation is working fine again (and my MFT is much faster without Sirius, go figure...).

I have only had my car for 4 months, it shouldnt be ending soon.

I will be trying the fuse tonight, but I did ask my dealer if they could do it (I hate taking out those fuses, such a pain to get to) but they would not offer to do it, instead they just kept referring back to that bulletin.

Ill update this post once I try the fuse thing tonight. I have a feeling it will work.
 

·
Registered
Joined
·
1,159 Posts
I had once this message. All I did was to pull the SD card and then reinsert it in and everything was back to normal. Never had this message since (one and a half month already).
 

·
Registered
Joined
·
122 Posts
Discussion Starter #6
I had once this message. All I did was to pull the SD card and then reinsert it in and everything was back to normal. Never had this message since (one and a half month already).
I did that a dozen times. Even did the "Master Reset" within the sync system.

Still happens. Gotta try the fuse pull tonight.
 

·
Registered
Joined
·
182 Posts
Mine did that once in a while and would set itself up not long after hitting ok. Today, going to and from work, I kept getting that error message pop up continuously. Every time I'd hit ok, navigation fault corrected itself and then it started all over again. At one point I didn't want to hit the ok button because I didn't care for it any longer but then I'd get no volume for the radio or access to anything else. Anyway... I'm going to think that it's because it was super cold today and that the system was probably just frozen. Tomorrow temps will be much warmer and I'll go for a quick drive to see if it's fixed itself up.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #9
Just got home from a mini get together before new years and played some tunes in my car (without the SD card in) and I am actually really glad Ford got me to do a master reset, even if it didnt fix my nav issue, because now I no longer have a 5-7 second delay between songs, its like 1 second now. Pretty happy about that.

Anyways, since its late I never got chance to pull the fuse, will have to do that tomorrow after work. Will report back in on what I figure out incase anyone else ever has this issue.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #10
Well sure enough, I pulled the fuse and it worked.

Kinda pissed that I suggested Ford try that and they basically told me theres nothing they can do (which I take as theres nothing they WILL do).

They will be hearing from me once the holidays are over. I am very disappointed that they couldnt do that when it took me 15 minutes max (let it sit for 10 minutes to make sure it cleared out).
 

·
Registered
Joined
·
399 Posts
That's usually something that a dealer will get the shop foreman to do (small fixits and PR type stuff) unless the shop foreman at your dealer is one of those guys who just runs around like a dork just to look busy. A tech wouldn't get paid to do that (Ford warranty would pay the tech a big whoppin' ZERO dollars since they are supposed to not attempt repairs at this time), which is why an hourly paid apprentice or shop foreman is usually the perfect person to check that stuff out.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #12
Why did I get 0 help period? I thought I bought a new car with a warranty so I wouldnt have to fix all these small little things?
 

·
Registered
Joined
·
143 Posts
Why did I get 0 help period? I thought I bought a new car with a warranty so I wouldnt have to fix all these small little things?
I'm finding a real disconnect between Ford and the dealers actually. I had to argue with my service manager about the transmission update (mine is a May build) and they had no idea about it (late October when I brought it to their attention). They agreed to do it but only as an effort to make me happy as a customer (I've not yet had it done though, their IDS was out of date and couldn't perform at the level needed for this update).

I question why Mulally can admit to the programming issue to USA Today (I believe) and the dealers have no idea. I was "warned" by my service manager about those "forums" and the misinformation that can come from them. If it weren't for this group how would we know that the issues we're seeing are in fact real when our dealers have no idea?

There's a real bad communication problem between the mother ship and the satellites. I'm convinced of it.

Joe
 

·
Registered
Joined
·
155 Posts
I'm finding a real disconnect between Ford and the dealers actually. I had to argue with my service manager about the transmission update (mine is a May build) and they had no idea about it (late October when I brought it to their attention). They agreed to do it but only as an effort to make me happy as a customer (I've not yet had it done though, their IDS was out of date and couldn't perform at the level needed for this update).

I question why Mulally can admit to the programming issue to USA Today (I believe) and the dealers have no idea. I was "warned" by my service manager about those "forums" and the misinformation that can come from them. If it weren't for this group how would we know that the issues we're seeing are in fact real when our dealers have no idea?

There's a real bad communication problem between the mother ship and the satellites. I'm convinced of it.

Joe
Not so at all Joe. All the info is at the dealers finger tips. The oasis system updates us every day on the sync system issues and updates . People the latest version software is BM, the new software updates are coming this month for you my touch peeps. I will tell you that the software you have at this time can be reset by pulling the fuse or disconnecting the poss battery connection for 10 min. After you dump your system wait for everything to reboot and your up and running again.
 

·
Registered
Joined
·
27 Posts
Mine drives me nuts and the car isn't a week old. The Nav pulled the fault day TWO of ownership.. PLUS my clock won't hold time .. the outside temp reading is WAY off by a good 25 degrees and... I'm always driving west for the compass :) They told me all of those things are the result of the bad nav... I'll know more Friday 1/6/2012 when I bring it in to service this,.. We'll see..
 

·
Registered
Joined
·
3 Posts
Navigation Fault

I just picked up my focus on 12/29. Upon delivery it was noticed that the navigation gave the same error as shown in this thread with a red "X" through the GPS icon when looking at the map. No matter where I am it seems that ti can not get any GPS signal it always shows me at the dealership. Originally I thought no big problem, I will drop it off to service and they will reset it, plugged the antenna or something. But with the long weekend I just got a phone call from the service manager this morning. He told me that it was a software issue. Ford is in the process of getting an update, but he is being told that it will be ready at some point during the first quarter. WTF??? I bought the car, no one told me that one of the main features that I was looking for will be useless for 3 months! I wrote an email to the sales person and the general manager asking what Ford is going to do about this. But then I started looking online and I have not seen this same issue being discussed until I found this thread. Has anyone been given the same explanation or am I being fed a bunch of BS?

Sorry for the long post.
 

·
Registered
Joined
·
1,159 Posts
I just picked up my focus on 12/29. Upon delivery it was noticed that the navigation gave the same error as shown in this thread with a red "X" through the GPS icon when looking at the map. No matter where I am it seems that ti can not get any GPS signal it always shows me at the dealership. Originally I thought no big problem, I will drop it off to service and they will reset it, plugged the antenna or something. But with the long weekend I just got a phone call from the service manager this morning. He told me that it was a software issue. Ford is in the process of getting an update, but he is being told that it will be ready at some point during the first quarter. WTF??? I bought the car, no one told me that one of the main features that I was looking for will be useless for 3 months! I wrote an email to the sales person and the general manager asking what Ford is going to do about this. But then I started looking online and I have not seen this same issue being discussed until I found this thread. Has anyone been given the same explanation or am I being fed a bunch of BS?

Sorry for the long post.
I think you are being fed a bunch of BS. Yes, some of us have an issue due to the Navigation SD card, but NONE of us had a problem like yours: GPS not available ! Your problem is not one that can be solved with a software update. So, IMO, go and ask them to take care of your unit, because the "update" has nothing to do with your GPS not being able to see the satelite.
 

·
Registered
Joined
·
772 Posts
Here lies the problem now.....dealers are taking this communcition from Ford as a blanket excuse to not service anything related to MFT.

It's not acceptable if your navigation is inoperable if you bought a car with that option. It doesn't matter if an update is coming. You bought the car to use the feature upon delivery.
 

·
Registered
Joined
·
80 Posts
I think you are being fed a bunch of BS. Yes, some of us have an issue due to the Navigation SD card, but NONE of us had a problem like yours: GPS not available ! Your problem is not one that can be solved with a software update. So, IMO, go and ask them to take care of your unit, because the "update" has nothing to do with your GPS not being able to see the satelite.
they should at least be able to check the antenna wiring to make sure it's all connected. i too have had the red x show up but it's when i'm underground parking structures (as one would assume). can you call another ford dealer to have them check the problem -- if the one you're dealing with is refusing to service it, go somewhere else.
 

·
Registered
Joined
·
182 Posts
Mine did that once in a while and would set itself up not long after hitting ok. Today, going to and from work, I kept getting that error message pop up continuously. Every time I'd hit ok, navigation fault corrected itself and then it started all over again. At one point I didn't want to hit the ok button because I didn't care for it any longer but then I'd get no volume for the radio or access to anything else. Anyway... I'm going to think that it's because it was super cold today and that the system was probably just frozen. Tomorrow temps will be much warmer and I'll go for a quick drive to see if it's fixed itself up.
I wanted to add that when the tempatures went back to "normal", my GPS went back to working fine. Just like any electronic devices, when frozen, it doesn't work.
 
1 - 20 of 40 Posts
Top