Focus Fanatics Forum banner

181 - 200 of 200 Posts

·
Focus Addict
Joined
·
14,131 Posts
I was considering doing this "mod" since everyone seems to rave about it. I've seen that the popular/budget-friendly choice is the ERMM. So I did some googling and found FSWERKS sells these, but in the description is says:

"Note: Ford updated to this mount in approx mid-2014 models thus newer vehicles should already be equipped with this mount, please check your vehicle prior to ordering if you are upgrading. This lower engine mount was the factory original part for 2011-present Ford Focus electric, S, SE, SEL, Titanium and came as original equipment on the 2015-2016 Focus ST and 2016-2017 Focus RS."

So technically, this shouldn't be an issue for 2015+ models (aka facelift or MK3.5) right? But I've noticed some 2015 owners in this thread has upgraded their RMM's anyway. Can someone verify this? If their 2015+ model came with the ERMM from the factory or not? I would check myself, but I don't have the equipment or tools. I'd greatly appreciate it. Thanks!
I think it was just the ST who got this as factory after 14.

Sent from my SM-G920T using FF Mobile
Yup, USDM spec Focus STs are the only ones that get the FFE RMM in the petrol powered version of the car. Not sure what the RS has, but it probably won't be the same as the base model either.
 

·
Registered
Joined
·
26 Posts
Thanks guys! Bittersweet moment -- I always felt there was much to be desired, but now I have to spend money. [scratch]
 

·
Registered
Joined
·
11 Posts
I can confirm also that the ERRM is used by the newest Focus RS MK3. As i have bought mine E-RRM as a removal part from RS3 [burnout]

And i can also confirm that in the 2.0EB Focus MK3.5 ST (2015-) is also E-RRM as one of my friend did the upgrade with Mountune Roll Restrictor and the stock part was actually the E-RRM.
 

·
Registered
Joined
·
26 Posts
I can confirm also that the ERRM is used by the newest Focus RS MK3. As i have bought mine E-RRM as a removal part from RS3 [burnout]

And i can also confirm that in the 2.0EB Focus MK3.5 ST (2015-) is also E-RRM as one of my friend did the upgrade with Mountune Roll Restrictor and the stock part was actually the E-RRM.
Appreciate the intel. Thank you!
 

·
Registered
Joined
·
198 Posts
I know that I am late on this thread, but all the initial photos from ShoOff are gone thanks to stinking photobucket and their greed.

Is there any way ShoOff can repost his photos in one post here? Or does anyone else have all them?
 

·
Registered
Joined
·
2,173 Posts
I know that I am late on this thread, but all the initial photos from ShoOff are gone thanks to stinking photobucket and their greed.

Is there any way ShoOff can repost his photos in one post here? Or does anyone else have all them?
I've been trying to download a lot of the guide photos and reupload them elsewhere... But Photobucket is now cancer.

You're better off using YT.

 

·
Registered
Joined
·
18 Posts
Thanks for the pics! Very helpful.

I just did the rear motor mount and the passenger-side motor mount with OEM mounts, and I feel a HUGE difference, especially since my passenger-side mount was beat to a pulp.

Getting ready to do the transmission mount next, but from what I can tell that's going to be a more labor intensive job and I'll have to do it this weekend when there's enough sunlight.
 

·
Registered
Joined
·
2,173 Posts
Thanks for the pics! Very helpful.

I just did the rear motor mount and the passenger-side motor mount with OEM mounts, and I feel a HUGE difference, especially since my passenger-side mount was beat to a pulp.

Getting ready to do the transmission mount next, but from what I can tell that's going to be a more labor intensive job and I'll have to do it this weekend when there's enough sunlight.
From my understanding, it's unlikely that your transmission mount/driver side motor mount failed.

Unless it's preemptive.
 

·
Registered
Joined
·
18 Posts
Yeah, it's preemptive, although I had to do it twice today. The first time I did it I wasn't sure how tight I'd need to torque the bolt holding onto the transmission, and the transmission literally dropped as I was driving today.

Luckily I don't think I did any damage, and was able to pick up my tools with my work truck and fix it by the side of the road. This time I torqued that sucker up to wazoo! Best to have all new mounts, try to match how the car drove when new, as factory designed.
 

·
Registered
Joined
·
159 Posts
I need advice. I'm not sure about the rear motor mount but I was thinking about changing the top mount. I've noticed that it feels like my vibration at idle has just gone up, and it feels like there's more vibration suddenly when accelerating, in the gas pedal.

Could the motor mount(s) be to blame? I told my older brother the mileage (80k) and he acted like it wasn't even possible. Said "maybe at 200k"

I don't know. I got in the car last week to go to work and something felt different. It's frustrating. I just changed the purge valve. I really don't want to add a problem list but come on, I drive it every day. I think my intuition tells me something isn't quite right.

Sent from my Pixel 2 XL using Tapatalk
 

·
Registered
Joined
·
18 Posts
Yeah, my passenger-side mount was beat to a pulp when I changed it at 88k miles. It's more than possible that it's worn and causing vibration and worse handling. Chances are that's the only mount that's giving you issues, though, as that's the weakest mount/the one carrying the greatest burden out of all 3.

After I replaced mine, the car handles significantly better, and vibration has been minimized considerably.
 

·
Registered
Joined
·
861 Posts
Could the motor mount(s) be to blame? I told my older brother the mileage (80k) and he acted like it wasn't even possible. Said "maybe at 200k"
For most other cars, he'd be correct. Search here and you'll see a lot of failed passenger mounts at < 80K. I recently changed mine at 110K+, but I suspect it started leaking many miles ago. The vibe kept getting worse on shifts.

Waaaay freakin better after changing the mount.
 

·
Registered
Joined
·
159 Posts
Do you guys know where I can get the top mount for a good price? Didn't see the OEM Ford one on Rock Auto. I even told my brother I thought the Focus goes through them quick and he didn't seem to think so.

I'm considering the E Focus as well on my NA, but added vibrations are something I DON'T want.

I'm thinking crap front tires and the motor mount have started making my car feel like real poo at times as far as handling. I'm looking at some money anyways. I also need to change the trans fluid.

$-$-$

Sent from my Pixel 2 XL using Tapatalk
 

·
Registered
Joined
·
159 Posts
I used fordpartsgiant.com, which has OEM parts for a relatively inexpensive price after shipping.
I actually just ordered from there. Looks like that site has a great reputation. The site says parts usually arrive within 1-3 days after shipping. They send them out from authorized dealerships

So does the part include the bracket or do I have to remove the old one and install the new mount in it?

Sent from my Pixel 2 XL using Tapatalk
 

·
Registered
Joined
·
180 Posts
Got the pmm insert for about $15, had to pry the old one out and beat the tabs down on the new one, if they go out this quick it's a good thing they are cheap
 

·
Registered
Joined
·
159 Posts
I just changed the passenger mount this past weekend and as soon as I started up the car, I couldn't believe how much better it felt. I can physically feel the car shifts less than before. I also seemed to have more vibration in my gas pedal than normal, and it seems even that improved.

Looks like I'll be replacing the mount every 70-80k. Now to get my front door speakers and tweeters changed and buy an amp for them.

Sent from my Pixel 2 XL using Tapatalk
 
181 - 200 of 200 Posts
Top