Focus Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
I own a 2014 Focus Titanium with MFT and Push Button start. When the temperature is 20 degrees or lower I have a problem with the MFT and interior lights staying on after the car is shut down and the door is opened. I have taken it to the dealer and they won't check anything because they can't duplicate the problem. Very aggravated. I finally captured the problem on video so I am hoping that is enough to get them to trace down the issue. Any suggestions? Anyone else seen this before?

I can't seem to find a thread that matches my issue, maybe I am searching for the wrong key words.
 

·
Premium Member
Joined
·
44,595 Posts
Moved to the MkIII section for more looks from other owners.
 

·
Registered
Joined
·
5,887 Posts
I own a 2014 Focus Titanium with MFT and Push Button start. When the temperature is 20 degrees or lower I have a problem with the MFT and interior lights staying on after the car is shut down and the door is opened. I have taken it to the dealer and they won't check anything because they can't duplicate the problem. Very aggravated. I finally captured the problem on video so I am hoping that is enough to get them to trace down the issue. Any suggestions? Anyone else seen this before?

I can't seem to find a thread that matches my issue, maybe I am searching for the wrong key words.
I'm happy to look into this further. Please send me a private message with your VIN, mileage, best daytime phone number, full name, and dealer name/location.

Meagan
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
Problem found!

After Meagan kindly bumped my issue, we have a dealer that found the problem. Left my car with them Thursday night because of the low temps expected for Friday. The Tech went out to the car and duplicated the problem. It is a faulty sensor in the latch of the driver side door. Unfortunately the part is on national back order but for now I can wiggle the latch to make it work until my part comes in.

I wanted to also give you all some additional details with this problem that I noted as it got worse.

1. When I would open the door with the car running and the fob in my pocket the display would not tell me that the engine was on and it would not "ding".
2. When I would get out the car with the engine on it would not honk to remind me that the car was running.
3. When you would look at the display it would not tell you that the Ford Key was missing.
4. When you turn the car off the MFT would stay on, radio would play, and center info display would sometimes stay lit even with the door open. Interior lights would stay on also.

The only odd thing about all this was that you would think it would do it no matter what the temperature was but it didn't start until we had temps that were consistently in the 20 degree or lower range. If it was above 20 it operated normally.

The important thing is that it will be fixed.
 

·
Registered
Joined
·
1 Posts
I have the same problem with my 2014 titanium, the radio and lights stays on when I open the door at lower temps took the car to dealer and they would not fix it because it was working like it should thank you for the insight I might just take a video of it and show it to him
 

·
Registered
Joined
·
100 Posts
my drivers door will not unlock/lock by hand. After the car runs and warms up, it will work, Pass door works fine. I noticed on dash the red square would flash, but using pass door it flashed yellow and unlocked. Taking to dealer tomorrow morning.
 

·
Registered
Joined
·
5,887 Posts
After Meagan kindly bumped my issue, we have a dealer that found the problem...
Glad to be of service!

I have the same problem with my 2014 titanium, the radio and lights stays on when I open the door at lower temps took the car to dealer and they would not fix it because it was working like it should thank you for the insight I might just take a video of it and show it to him
my drivers door will not unlock/lock by hand. After the car runs and warms up, it will work, Pass door works fine. I noticed on dash the red square would flash, but using pass door it flashed yellow and unlocked. Taking to dealer tomorrow morning.
Hi guys,

I'm happy to send this up the chain for you, too. Please send me a private message with your VIN, mileage, best daytime phone, full name, and dealer name/location.

Meagan
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #9 ·
I have the same problem with my 2014 titanium, the radio and lights stays on when I open the door at lower temps took the car to dealer and they would not fix it because it was working like it should thank you for the insight I might just take a video of it and show it to him
Shawn1774, Just know that they will not perform any work based on a video. I offered the same thing but had much more success with Meagan. I provided as many details as possible to the dealer. For me the temps were the key thing and it always did it based on that so when the original dealer told me that they could not duplicate the problem I suspected that they 1. didn't really check it out or 2. checked it under the wrong conditions (temp was too warm). Now that I had a second dealer that followed my instructions, the problem was duplicated. If possible, leave it with them overnight.
 

·
Registered
Joined
·
5,887 Posts
Shawn1774, Just know that they will not perform any work based on a video. I offered the same thing but had much more success with Meagan. I provided as many details as possible to the dealer...
Happy to be of assistance! :D

Meagan
 
1 - 10 of 10 Posts
Top