Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
When I'm in 1st, 2nd, or 3rd going pretty slow, about 25 mph or so, my car will occasionally buck violently. It doesn't happen all the time but pretty often. Could it be a bad IMRC? Are there ways of diagnosing it? Or (sorry if this is doesn't make any sense) could it be the clutch going? I'm not quite sure what could be wrong. Car has 180k miles
 

·
Premium Member
Joined
·
21,256 Posts
Do you have a CEL? Do you have a scanner?

If no CEL, the most likely cause is bad gas. Try filling up at a different station for a few fill-ups. I had to quit using the convenient Mapco on the way to work due to the same problem. Shame too, there were some nice bubble butts in there I enjoyed seeing in the morning.

It's fairly cheap- compared to replacing parts- to try this first.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #5 ·
Yes and no to the CEL. About a month ago my check engine came on. Went off the next day. Week later light came on again and same thing happened. Check engine light is still not on but I checked it the other say with my xcal4 tuner and I had p0133 and 01246. Cleared the codes and now they're not showing back up. I've driven 165 miles since then and had multiple cold starts as well.

But I do not fill up at the same station regularly. It varies from Shell, to Exon, to Ingles, etc.

I did replace my passenger side mount a while ago as well as my dog bone mount. I'll check them tomorrow and make sure every thing is tight.
 
1 - 5 of 5 Posts
Top