Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
21,250 Posts
Discussion Starter #1
Has anyone had a problem with these making noise after installing them?

I have to go get my grease gun out of storage, but I could swear that I saw grease in the nipple on at least one joint. I'd think these were pre greased anyway.

I pushed on the wheel last night and got some clicking that appeared to be coming from the end links, but I didn't take the wheel off to verify. The whole thing blows, install SVT brakes, new end links, and get a worse sounding suspension than before.
 

·
Premium Member
Joined
·
21,250 Posts
Discussion Starter #3
I'll grease them ASAP and see if that helps.

Now comes the time to see if I can even find my freaking grease gun. I had 2 at one time. Maybe I'll just get 3, there are so few things that actually use grease nipples these days that I forget where the darn thing is after I use it.
 

·
Registered
Joined
·
3,022 Posts
The grease that comes with them is simply and assembly lube and to prevent corrosion while shipping and sitting on a shelf.
 

·
Focused Focus
Joined
·
6,403 Posts
If these are the ones you got from me, they are warrantied if theres a problem.
 

·
Focus Fanatic
Joined
·
7,252 Posts
Yep, you HAVE to grease these with a good chassis grease before you install them.
It is also recommended to grease them every 3k miles.
I didn't grease my first set, and they went bad because of it,
so I had to buy a whole new set. Rockauto wouldn't warrenty them either
because I didn't grease them from the start like I was supposed to.
There went $56 right out the window..........
 
1 - 6 of 6 Posts
Top