Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Steve mk1focusst

Whwn i drive my st170 every now and then it looses power. I have no warning lights on the dash. I have changed the spark plugs. Ht leads . Coil pack gave it a service.
I have been told it could be fuel pump. Air leak from the in let manifold. Lamba sencors. Cat. Any ideas please
 

·
Registered
Joined
·
1,710 Posts
Steve mk1focusst

Whwn i drive my st170 every now and then it looses power. I have no warning lights on the dash. I have changed the spark plugs. Ht leads . Coil pack gave it a service.
I have been told it could be fuel pump. Air leak from the in let manifold. Lamba sencors. Cat. Any ideas please
Get the Torque app and a obd2 adaptor.
With Torque, you'll be able to watch fuel pressure, fuel trims, timing, etc..

Sent from my SAMSUNG-SGH-I527 using Tapatalk
 

·
Registered
Joined
·
56 Posts
Check your PCV hose on the back of the engine. If you have stuttering, especially while cruising, this is a common issue. It will slowly get worst until your car won't run at all. It's an easy check and an easy fix.
 

·
Registered
Joined
·
3 Posts
Steve mk1focusst

Whwn i drive my st170 every now and then it looses power. I have no warning lights on the dash. I have changed the spark plugs. Ht leads . Coil pack gave it a service.
I have been told it could be fuel pump. Air leak from the in let manifold. Lamba sencors. Cat. Any ideas please. Visit Autofthings to view the best battery tender that you may concern.
It seems an intake manifold leak (vac) from the seals. These gaskets have been revised from the original. Take a look at this.
 
1 - 5 of 5 Posts
Top