Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Howdy folks,

New to the forum and looking for some tech advice. Can you tell me what each of these units are, located on or near the top of the bulkhead on my Focus?

The vehicle is a year 2000 Mk1 with the 1.8 endura diesel. I'm also attaching a picture of the rocker cover to aid identification.

The engine's been sluggish for a while, with *mahussive* turbo lag, but once it's up 60+mph it's ok. I've ordered a new MAF sensor, but I'm also wondering if it could be an EGR problem - I've a feeling that some of these units could be to do with the EGR, but I'm not sure. Two pictures show what could be missing vacuum pipes (circled) - maybe??

Any advice much appreciated!

Theo

PS: This Focus has been an absolute hero (hence the user name) - ultra reliable *touch wood*, cheap as chips to run and maintain, comfortable, practical and fun to drive. Top car! [loveff]
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Cool, thanks polygon!

Am I right that the MAP sensor should have a vacuum pipe coming out of it (see 2nd picture). Where should the pipe go to?

And in the 3rd picture, is that a breather, or a missing pipe?
 

·
Registered
Joined
·
321 Posts
Cannot say I am familiar with your engine but what is certain is that the MAP needs to measure the pressure in the intake manifold. Seems to me that pic #2 & #3 are related and the image below shows a hose that looks very similar to the one that has been severed between those 2 places.

As to why this pipe has been removed I'm not sure. Maybe the EGR has been blanked by a previous owner in an attempt to boost power ?
 

Attachments

1 - 6 of 6 Posts
Top