Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
So hello everyone, I need some sort of help with the next problem.

I have a '99 focus 2.0 trend zetec mtx-75 and I have some issues with my speedometer.
My km/u m/h clock doesn't work it just keeps still at 0 no matter how hard I drive. I already replaced my VSS for a new one (imitation from a company called "hoffer") my rpm temperature and gasoline meter all work without any problems. I've already tried another unit I got from a friend of mine, when I first installed it the unit calibrated itself. Going from zero to max and back. After that nothing changed. Do I need to unplug the power supply to my car after installing a new VSS or a new unit? If not, what could the problem possibly be? I've been to a company here that specializes in fixing up dashboard units and they told me that since my car also doesn't register any driven miles the problem is in the car, and not in the unit, but I don't know how to go around this problem. What is the best way of sorting out what the problem could be?

Thanks I'm advance!
Thomas
 

·
Vince your Moderator
Joined
·
5,074 Posts
UK or, AUS?
 

·
Registered
Joined
·
1,212 Posts
Usually it's the cable itself that's the issue if your rpm gauge works but the speedo doesn't, and you've already tried the VSS.

Did you have transmission work done lately? I had a mechanic once simply forget to reconnect the speedo cable after replacing the clutch.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
not that i know off, and after we swapped the VSS we put the cable on ourselfs, so that has to be right, could it be that my vss is not inserted far enough into my engine?
 

·
Registered
Joined
·
1,212 Posts
we put the cable on ourselfs, so that has to be right
Might be worth doing a double-check to make sure the cable is in tight on both ends with no retainers broken, and the VSS is seated properly and not in cockeyed or something.

Also worth disconnecting the battery for 30 mins or so to see if resetting the ECU helps. I'm not sure how different Euro Foci are from my NA model.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
what do you mean with clockeyed? i'll check my cable tomorrow, first thing. and i'll take the power away from my car for half an hour
will keep you updated
 
1 - 9 of 9 Posts
Top